summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKevin Steves <stevesk@pobox.com>2001-07-15 02:09:28 +0000
committerKevin Steves <stevesk@pobox.com>2001-07-15 02:09:28 +0000
commit6482ec865ab7c38a32f2dd431922f75f1c785c43 (patch)
tree47d3a8d02d39036e0ad791f593d4c995c41357c6 /configure.in
parent60193f70f7f246eb4a4b3530fa25323e6ba5f683 (diff)
- (stevesk) configure.in: use ll suffix for long long constant
in snprintf() test
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d3f38b92f..336d4056e 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
1# $Id: configure.in,v 1.299 2001/07/14 03:22:53 djm Exp $ 1# $Id: configure.in,v 1.300 2001/07/15 02:09:29 stevesk Exp $
2 2
3AC_INIT(ssh.c) 3AC_INIT(ssh.c)
4 4
@@ -1044,7 +1044,7 @@ main()
1044#if (SIZEOF_LONG_INT == 8) 1044#if (SIZEOF_LONG_INT == 8)
1045 long int num = 0x7fffffffffffffff; 1045 long int num = 0x7fffffffffffffff;
1046#else 1046#else
1047 long long num = 0x7fffffffffffffff; 1047 long long num = 0x7fffffffffffffffll;
1048#endif 1048#endif
1049 strcpy(expected_out, "9223372036854775807"); 1049 strcpy(expected_out, "9223372036854775807");
1050 snprintf(buf, mazsize, "%lld", num); 1050 snprintf(buf, mazsize, "%lld", num);