summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-01-17 21:40:06 +1100
committerDamien Miller <djm@mindrot.org>2000-01-17 21:40:06 +1100
commit6640995be8a3fde9636c7a5aae539966eb989ee6 (patch)
treedc1a58ee50616a0ecf3458a0cffdbdc21098e4da /configure.in
parentb284b546c092f5f9f8c509c8b49f7d57233a5f3f (diff)
- Patch from Christos Zoulas <christos@zoulas.com>
- Try $prefix first when looking for OpenSSL. - Include sys/types.h when including sys/socket.h in test programs
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 15 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 7c0b1491b..e7524cd62 100644
--- a/configure.in
+++ b/configure.in
@@ -96,7 +96,7 @@ esac
96 96
97dnl Check for OpenSSL/SSLeay directories. 97dnl Check for OpenSSL/SSLeay directories.
98AC_MSG_CHECKING([for OpenSSL/SSLeay directory]) 98AC_MSG_CHECKING([for OpenSSL/SSLeay directory])
99for ssldir in /usr /usr/local/openssl /usr/lib/openssl /usr/local/ssl /usr/lib/ssl /usr/local $prefix /usr/pkg ; do 99for ssldir in $prefix /usr /usr/local/openssl /usr/lib/openssl /usr/local/ssl /usr/lib/ssl /usr/local $prefix /usr/pkg ; do
100 if test -f "$ssldir/include/openssl/crypto.h"; then 100 if test -f "$ssldir/include/openssl/crypto.h"; then
101 AC_DEFINE(HAVE_OPENSSL) 101 AC_DEFINE(HAVE_OPENSSL)
102 GOT_SSL="yes" 102 GOT_SSL="yes"
@@ -246,7 +246,10 @@ AC_TRY_COMPILE(
246 246
247AC_MSG_CHECKING([for struct sockaddr_storage]) 247AC_MSG_CHECKING([for struct sockaddr_storage])
248AC_TRY_COMPILE( 248AC_TRY_COMPILE(
249 [#include <sys/socket.h>], 249 [
250 #include <sys/types.h>
251 #include <sys/socket.h>
252 ],
250 [struct sockaddr_storage s;], 253 [struct sockaddr_storage s;],
251 [ 254 [
252 AC_DEFINE(HAVE_STRUCT_SOCKADDR_STORAGE) 255 AC_DEFINE(HAVE_STRUCT_SOCKADDR_STORAGE)
@@ -280,6 +283,7 @@ AC_TRY_COMPILE(
280AC_MSG_CHECKING([for struct addrinfo]) 283AC_MSG_CHECKING([for struct addrinfo])
281AC_TRY_COMPILE( 284AC_TRY_COMPILE(
282 [ 285 [
286 #include <sys/types.h>
283 #include <sys/socket.h> 287 #include <sys/socket.h>
284 #include <netdb.h> 288 #include <netdb.h>
285 ], 289 ],
@@ -432,7 +436,10 @@ AC_EGREP_HEADER(ut_addr_v6, utmpx.h,
432 436
433AC_MSG_CHECKING([whether struct sockaddr_storage has ss_family field]) 437AC_MSG_CHECKING([whether struct sockaddr_storage has ss_family field])
434AC_TRY_COMPILE( 438AC_TRY_COMPILE(
435 [#include <sys/socket.h>], 439 [
440 #include <sys/types.h>
441 #include <sys/socket.h>
442 ],
436 [struct sockaddr_storage s; s.ss_family = 1;], 443 [struct sockaddr_storage s; s.ss_family = 1;],
437 [ 444 [
438 AC_DEFINE(HAVE_SS_FAMILY_IN_SS) 445 AC_DEFINE(HAVE_SS_FAMILY_IN_SS)
@@ -442,7 +449,10 @@ AC_TRY_COMPILE(
442) 449)
443AC_MSG_CHECKING([whether struct sockaddr_storage has __ss_family field]) 450AC_MSG_CHECKING([whether struct sockaddr_storage has __ss_family field])
444AC_TRY_COMPILE( 451AC_TRY_COMPILE(
445 [#include <sys/socket.h>], 452 [
453 #include <sys/types.h>
454 #include <sys/socket.h>
455 ],
446 [struct sockaddr_storage s; s.__ss_family = 1;], 456 [struct sockaddr_storage s; s.__ss_family = 1;],
447 [ 457 [
448 AC_DEFINE(HAVE___SS_FAMILY_IN_SS) 458 AC_DEFINE(HAVE___SS_FAMILY_IN_SS)
@@ -636,7 +646,7 @@ dnl Use ip address instead of hostname in $DISPLAY
636AC_ARG_WITH(ipaddr-display, 646AC_ARG_WITH(ipaddr-display,
637 [ --with-ipaddr-display Use ip address instead of hostname in \$DISPLAY], 647 [ --with-ipaddr-display Use ip address instead of hostname in \$DISPLAY],
638 [ 648 [
639 if test "x$withval" != "xno" ; then 649 if test "x$withval" = "xno" ; then
640 AC_DEFINE(IPADDR_IN_DISPLAY) 650 AC_DEFINE(IPADDR_IN_DISPLAY)
641 fi 651 fi
642 ] 652 ]