summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-11-22 14:27:24 +1100
committerDamien Miller <djm@mindrot.org>1999-11-22 14:27:24 +1100
commit859cec02509ae0d3e2f34051d0f9d7366b6ca62f (patch)
treee42b4d63f2b16bc7646fa95990ba27dad445e87a /configure.in
parentb3ca3aa12f8248c2d9e23f15a46e0f3c97397e54 (diff)
- Added autoconf test and macro to deal with old PAM libraries
pam_strerror definition (one arg vs two).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 18 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 1fe0c30b4..0678fa4c8 100644
--- a/configure.in
+++ b/configure.in
@@ -77,7 +77,7 @@ AC_CHECK_SIZEOF(long int, 4)
77AC_CHECK_SIZEOF(long long int, 8) 77AC_CHECK_SIZEOF(long long int, 8)
78 78
79dnl More checks for data types 79dnl More checks for data types
80AC_MSG_CHECKING([For quad_t]) 80AC_MSG_CHECKING([for quad_t])
81AC_TRY_COMPILE( 81AC_TRY_COMPILE(
82 [#include <sys/types.h>], 82 [#include <sys/types.h>],
83 [quad_t a; a = 1235;], 83 [quad_t a; a = 1235;],
@@ -88,7 +88,7 @@ AC_TRY_COMPILE(
88 [AC_MSG_RESULT(no)] 88 [AC_MSG_RESULT(no)]
89) 89)
90 90
91AC_MSG_CHECKING([For intXX_t types]) 91AC_MSG_CHECKING([for intXX_t types])
92AC_TRY_COMPILE( 92AC_TRY_COMPILE(
93 [#include <sys/types.h>], 93 [#include <sys/types.h>],
94 [int16_t a; int32_t b; a = 1235; b = 1235;], 94 [int16_t a; int32_t b; a = 1235; b = 1235;],
@@ -99,7 +99,7 @@ AC_TRY_COMPILE(
99 [AC_MSG_RESULT(no)] 99 [AC_MSG_RESULT(no)]
100) 100)
101 101
102AC_MSG_CHECKING([For u_intXX_t types]) 102AC_MSG_CHECKING([for u_intXX_t types])
103AC_TRY_COMPILE( 103AC_TRY_COMPILE(
104 [#include <sys/types.h>], 104 [#include <sys/types.h>],
105 [u_int16_t c; u_int32_t d; c = 1235; d = 1235;], 105 [u_int16_t c; u_int32_t d; c = 1235; d = 1235;],
@@ -121,6 +121,21 @@ AC_TRY_COMPILE(
121 [AC_MSG_RESULT(no)] 121 [AC_MSG_RESULT(no)]
122) 122)
123 123
124dnl Check PAM strerror arguments
125AC_MSG_CHECKING([whether pam_strerror takes only one argument])
126AC_TRY_COMPILE(
127 [
128 #include <stdlib.h>
129 #include <security/pam_appl.h>
130 ],
131 [(void)pam_strerror((pam_handle_t *)NULL, -1);],
132 [AC_MSG_RESULT(no)],
133 [
134 AC_DEFINE(HAVE_OLD_PAM)
135 AC_MSG_RESULT(yes)
136 ]
137)
138
124dnl Check whether use wants to disable the external ssh-askpass 139dnl Check whether use wants to disable the external ssh-askpass
125INSTALL_ASKPASS="yes" 140INSTALL_ASKPASS="yes"
126AC_MSG_CHECKING([whether to enable external ssh-askpass support]) 141AC_MSG_CHECKING([whether to enable external ssh-askpass support])