summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2001-09-18 14:01:11 +1000
committerDamien Miller <djm@mindrot.org>2001-09-18 14:01:11 +1000
commit85de580adcec0a5089ddddeda5cbbb519db35e50 (patch)
tree49698d20e3f140a11aa71723e603bcd016494baf /configure.in
parenta4f7ae1a35b5da61705bea75bcc50bc7a27726dd (diff)
- (djm) Configure support for smartcards
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 32 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 30415d94a..d873054fa 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
1# $Id: configure.in,v 1.309 2001/09/17 21:34:34 tim Exp $ 1# $Id: configure.in,v 1.310 2001/09/18 04:01:12 djm Exp $
2 2
3AC_INIT(ssh.c) 3AC_INIT(ssh.c)
4 4
@@ -1311,12 +1311,41 @@ fi
1311 1311
1312 1312
1313# Check whether user wants Kerberos support 1313# Check whether user wants Kerberos support
1314SCARD_MSG="no"
1315AC_ARG_WITH(smartcard,
1316 [ --with-smartcard Enable smartcard support],
1317 [
1318 if test "x$withval" != "xno" ; then
1319 if test "x$withval" != "xyes" ; then
1320 CPPFLAGS="$CPPFLAGS -I${withval}"
1321 LDFLAGS="$LDFLAGS -L${withval}"
1322 if test ! -z "$need_dash_r" ; then
1323 LDFLAGS="$LDFLAGS -R${withval}"
1324 fi
1325 if test ! -z "$blibpath" ; then
1326 blibpath="$blibpath:${withval}"
1327 fi
1328 fi
1329 AC_CHECK_HEADERS(sectok.h)
1330 if test "$ac_cv_header_sectok_h" != yes; then
1331 AC_MSG_ERROR(Can't find sectok.h)
1332 fi
1333 AC_CHECK_LIB(sectok, sectok_open)
1334 if test "$ac_cv_lib_sectok_sectok_open" != yes; then
1335 AC_MSG_ERROR(Can't find libsectok)
1336 fi
1337 AC_DEFINE(SMARTCARD)
1338 SCARD_MSG="yes"
1339 fi
1340 ]
1341)
1342
1343# Check whether user wants Kerberos support
1314KRB4_MSG="no" 1344KRB4_MSG="no"
1315AC_ARG_WITH(kerberos4, 1345AC_ARG_WITH(kerberos4,
1316 [ --with-kerberos4=PATH Enable Kerberos 4 support], 1346 [ --with-kerberos4=PATH Enable Kerberos 4 support],
1317 [ 1347 [
1318 if test "x$withval" != "xno" ; then 1348 if test "x$withval" != "xno" ; then
1319
1320 if test "x$withval" != "xyes" ; then 1349 if test "x$withval" != "xyes" ; then
1321 CPPFLAGS="$CPPFLAGS -I${withval}/include" 1350 CPPFLAGS="$CPPFLAGS -I${withval}/include"
1322 LDFLAGS="$LDFLAGS -L${withval}/lib" 1351 LDFLAGS="$LDFLAGS -L${withval}/lib"
@@ -2069,6 +2098,7 @@ echo " Random number collection: $RAND_MSG"
2069echo " Manpage format: $MANTYPE" 2098echo " Manpage format: $MANTYPE"
2070echo " PAM support: ${PAM_MSG}" 2099echo " PAM support: ${PAM_MSG}"
2071echo " KerberosIV support: $KRB4_MSG" 2100echo " KerberosIV support: $KRB4_MSG"
2101echo " Smartcard support: $SCARD_MSG"
2072echo " AFS support: $AFS_MSG" 2102echo " AFS support: $AFS_MSG"
2073echo " S/KEY support: $SKEY_MSG" 2103echo " S/KEY support: $SKEY_MSG"
2074echo " TCP Wrappers support: $TCPW_MSG" 2104echo " TCP Wrappers support: $TCPW_MSG"