summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-12-30 15:50:54 +1100
committerDamien Miller <djm@mindrot.org>1999-12-30 15:50:54 +1100
commit8bdeee25f8c0215812cdcdbd24f8c5b308a7b76a (patch)
tree3c6c86c231be661422c1b4fa2e6e16c4b6d4fc78 /configure.in
parent554ef3c7c205852592504d0433c592b1a7a8d459 (diff)
- Merged Dante SOCKS support patch from David Rankin
<drankin@bohemians.lexington.ky.us> - Updated documentation with ./configure options
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 39 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 3b1f125c6..4e5bc602d 100644
--- a/configure.in
+++ b/configure.in
@@ -17,7 +17,9 @@ dnl Use ip address instead of hostname in $DISPLAY
17AC_ARG_WITH(rsh, 17AC_ARG_WITH(rsh,
18 [ --with-rsh=PATH Specify path to remote shell program ], 18 [ --with-rsh=PATH Specify path to remote shell program ],
19 [ 19 [
20 AC_DEFINE_UNQUOTED(RSH_PATH, "$withval") 20 if test "x$withval" != "$xno" ; then
21 AC_DEFINE_UNQUOTED(RSH_PATH, "$withval")
22 fi
21 ], 23 ],
22 [ 24 [
23 AC_PATH_PROG(rsh_path, rsh) 25 AC_PATH_PROG(rsh_path, rsh)
@@ -367,6 +369,20 @@ if test ! -z "$nolastlog" ; then
367 AC_DEFINE(DISABLE_LASTLOG) 369 AC_DEFINE(DISABLE_LASTLOG)
368fi 370fi
369 371
372dnl Compile with dante SOCKS library
373AC_ARG_WITH(dante,
374 [ --with-dante=DIR Use Dante SOCKS lib (default is system library path)],
375 [
376 AC_DEFINE(HAVE_DANTE)
377 if test "x$withval" != "xno" ; then
378 if test -n $withval ; then
379 LIBS="$LIBS -L$withval"
380 fi
381 LIBS="$LIBS -lsocks"
382 fi
383 ]
384)
385
370AC_CHECK_FILE("/dev/ptmx", AC_DEFINE_UNQUOTED(HAVE_DEV_PTMX)) 386AC_CHECK_FILE("/dev/ptmx", AC_DEFINE_UNQUOTED(HAVE_DEV_PTMX))
371AC_CHECK_FILE("/dev/ptc", AC_DEFINE_UNQUOTED(HAVE_DEV_PTS_AND_PTC)) 387AC_CHECK_FILE("/dev/ptc", AC_DEFINE_UNQUOTED(HAVE_DEV_PTS_AND_PTC))
372 388
@@ -386,9 +402,11 @@ dnl Check whether user wants Kerberos support
386AC_ARG_WITH(kerberos4, 402AC_ARG_WITH(kerberos4,
387 [ --with-kerberos4 Enable Kerberos 4 support], 403 [ --with-kerberos4 Enable Kerberos 4 support],
388 [ 404 [
389 AC_DEFINE(KRB4) 405 if test "x$withval" != "$xno" ; then
390 LIBS="$LIBS -lkrb" 406 AC_DEFINE(KRB4)
391 CFLAGS="$CFLAGS -I/usr/include/kerberosIV" 407 LIBS="$LIBS -lkrb"
408 CFLAGS="$CFLAGS -I/usr/include/kerberosIV"
409 fi
392 ] 410 ]
393) 411)
394 412
@@ -396,8 +414,10 @@ dnl Check whether user wants AFS support
396AC_ARG_WITH(afs, 414AC_ARG_WITH(afs,
397 [ --with-afs Enable AFS support], 415 [ --with-afs Enable AFS support],
398 [ 416 [
399 AC_DEFINE(AFS) 417 if test "x$withval" != "$xno" ; then
400 LIBS="$LIBS -lkafs" 418 AC_DEFINE(AFS)
419 LIBS="$LIBS -lkafs"
420 fi
401 ] 421 ]
402) 422)
403 423
@@ -405,8 +425,10 @@ dnl Check whether user wants S/Key support
405AC_ARG_WITH(skey, 425AC_ARG_WITH(skey,
406 [ --with-skey Enable S/Key support], 426 [ --with-skey Enable S/Key support],
407 [ 427 [
408 AC_DEFINE(SKEY) 428 if test "x$withval" != "$xno" ; then
409 LIBS="$LIBS -lskey" 429 AC_DEFINE(SKEY)
430 LIBS="$LIBS -lskey"
431 fi
410 ] 432 ]
411) 433)
412 434
@@ -414,8 +436,10 @@ dnl Check whether user wants TCP wrappers support
414AC_ARG_WITH(tcp-wrappers, 436AC_ARG_WITH(tcp-wrappers,
415 [ --with-tcp-wrappers Enable tcpwrappers support], 437 [ --with-tcp-wrappers Enable tcpwrappers support],
416 [ 438 [
417 AC_DEFINE(LIBWRAP) 439 if test "x$withval" != "$xno" ; then
418 LIBWRAP="-lwrap" 440 AC_DEFINE(LIBWRAP)
441 LIBWRAP="-lwrap"
442 fi
419 ] 443 ]
420) 444)
421AC_SUBST(LIBWRAP) 445AC_SUBST(LIBWRAP)
@@ -423,7 +447,11 @@ AC_SUBST(LIBWRAP)
423dnl Check whether to enable MD5 passwords 447dnl Check whether to enable MD5 passwords
424AC_ARG_WITH(md5-passwords, 448AC_ARG_WITH(md5-passwords,
425 [ --with-md5-passwords Enable use of MD5 passwords], 449 [ --with-md5-passwords Enable use of MD5 passwords],
426 [AC_DEFINE(HAVE_MD5_PASSWORDS)] 450 [
451 if test "x$withval" != "$xno" ; then
452 AC_DEFINE(HAVE_MD5_PASSWORDS)
453 fi
454 ]
427) 455)
428 456
429dnl Check whether to enable utmpx support 457dnl Check whether to enable utmpx support