summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>1999-11-25 13:19:55 +1100
committerDamien Miller <djm@mindrot.org>1999-11-25 13:19:55 +1100
commit98ac007ad9e4b94c58e49b5ca86e9f444be930bd (patch)
treee66139db7d48bd90aa0b61b672a84a6d180acbf0 /configure.in
parent063fdf82755e53b5a2cf5265aaa654969b23b459 (diff)
Removed old with-askpass option
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in47
1 files changed, 12 insertions, 35 deletions
diff --git a/configure.in b/configure.in
index b0dde23ee..037478a6c 100644
--- a/configure.in
+++ b/configure.in
@@ -137,46 +137,23 @@ AC_TRY_COMPILE(
137 ] 137 ]
138) 138)
139 139
140dnl Check whether use wants to disable the external ssh-askpass 140AC_MSG_CHECKING([whether to build GNOME ssh-askpass])
141INSTALL_ASKPASS="yes" 141dnl Check whether user wants GNOME ssh-askpass
142AC_MSG_CHECKING([whether to enable external ssh-askpass support]) 142AC_ARG_WITH(gnome-askpass,
143AC_ARG_WITH(askpass, 143 [ --with-gnome-askpass Build the GNOME passphrase requester (default=no)],
144 [ --with-askpass=yes/no Enable external ssh-askpass support (default=yes)],
145 [ 144 [
146 if test x$withval = xno ; then 145 if test x$withval = xno ; then
147 INSTALL_ASKPASS="no" 146 GNOME_ASKPASS="";
148 else 147 else
149 INSTALL_ASKPASS="yes" 148 GNOME_ASKPASS="gnome-ssh-askpass";
150 fi 149 fi
151 ] 150 ])
152) 151AC_SUBST(GNOME_ASKPASS)
153if test "x$INSTALL_ASKPASS" = "xyes" ; then
154 AC_DEFINE(USE_EXTERNAL_ASKPASS)
155 AC_SUBST(INSTALL_ASKPASS)
156 AC_MSG_RESULT(yes)
157else
158 AC_MSG_RESULT(no)
159fi
160
161if test "x$INSTALL_ASKPASS" = "xyes" ; then
162 AC_MSG_CHECKING([whether to build GNOME ssh-askpass])
163 dnl Check whether user wants GNOME ssh-askpass
164 AC_ARG_WITH(gnome-askpass,
165 [ --with-gnome-askpass Build the GNOME passphrase requester (default=no)],
166 [
167 if test x$withval = xno ; then
168 GNOME_ASKPASS="";
169 else
170 GNOME_ASKPASS="gnome-ssh-askpass";
171 fi
172 ])
173 AC_SUBST(GNOME_ASKPASS)
174 152
175 if test -z "$GNOME_ASKPASS" ; then 153if test -z "$GNOME_ASKPASS" ; then
176 AC_MSG_RESULT(no) 154 AC_MSG_RESULT(no)
177 else 155else
178 AC_MSG_RESULT(yes) 156 AC_MSG_RESULT(yes)
179 fi
180fi 157fi
181 158
182dnl Check for user-specified random device 159dnl Check for user-specified random device