summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-02-10 14:37:55 +0000
committerColin Watson <cjwatson@debian.org>2014-02-10 14:37:55 +0000
commit11cbb530aa4ca54344eb8941342bfe510f4b981b (patch)
tree3cc6e4aa03bb76121fa1d4f8ee2fbcbdc6cdb5c1 /debian/rules
parente4c505521f820cadada465ebfa8ff12e3d37feb9 (diff)
Add systemd support (thanks, Sven Joachim; closes: #676830).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5b0d8f9d6..c8870b3a4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -114,7 +114,7 @@ confflags += --with-ldflags='$(strip -Wl,--as-needed $(default_ldflags))'
114confflags_udeb += --with-ldflags='-Wl,--as-needed' 114confflags_udeb += --with-ldflags='-Wl,--as-needed'
115 115
116%: 116%:
117 dh $@ --with=autoreconf 117 dh $@ --with=autoreconf,systemd
118 118
119autoreconf: 119autoreconf:
120 autoreconf -f -i 120 autoreconf -f -i
@@ -190,6 +190,9 @@ override_dh_installdocs:
190 # Avoid breaking dh_installexamples later. 190 # Avoid breaking dh_installexamples later.
191 mkdir -p debian/openssh-server/usr/share/doc/openssh-client 191 mkdir -p debian/openssh-server/usr/share/doc/openssh-client
192 192
193override_dh_systemd_enable:
194 dh_systemd_enable --name ssh
195
193override_dh_installinit: 196override_dh_installinit:
194 dh_installinit -R --name ssh -- start 16 2 3 4 5 . 197 dh_installinit -R --name ssh -- start 16 2 3 4 5 .
195 198