summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2003-09-01 01:34:19 +0000
committerColin Watson <cjwatson@debian.org>2003-09-01 01:34:19 +0000
commit2ee26b431f98cf1dc0e4fb9809ad1e0c879b8c08 (patch)
treeae95b7e0883aa778b6e67f4c50092a42d72ab949 /debian/rules
parent98fc03d946c636001a40e97082352911cb2e7f22 (diff)
Debian release 3.4p1-4.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 1 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 365872d3d..7615c8708 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,8 +11,6 @@ export DH_OPTIONS
11 11
12#PKG_VER = $(shell perl -e 'print <> =~ /\((.*)\)/' debian/changelog) 12#PKG_VER = $(shell perl -e 'print <> =~ /\((.*)\)/' debian/changelog)
13 13
14DEB_HOST_ARCH = $(shell dpkg-architecture -qDEB_HOST_ARCH)
15
16build: build-stamp 14build: build-stamp
17build-stamp: 15build-stamp:
18 dh_testdir 16 dh_testdir
@@ -23,7 +21,7 @@ build-stamp:
23 fi 21 fi
24 ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-ipv4-default \ 22 ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-ipv4-default \
25 --with-privsep-path=/var/run/sshd --without-rand-helper 23 --with-privsep-path=/var/run/sshd --without-rand-helper
26 $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-O2 -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \ 24 $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-O2 -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \
27 SSH_KEYSIGN='/usr/lib/ssh-keysign' 25 SSH_KEYSIGN='/usr/lib/ssh-keysign'
28 gcc -O2 `gnome-config --cflags gnome gnomeui` \ 26 gcc -O2 `gnome-config --cflags gnome gnomeui` \
29 contrib/gnome-ssh-askpass.c -o contrib/gnome-ssh-askpass \ 27 contrib/gnome-ssh-askpass.c -o contrib/gnome-ssh-askpass \
@@ -93,11 +91,6 @@ binary-arch: build install
93 test ! -e debian/tmp/etc/ssh/ssh_prng_cmds \ 91 test ! -e debian/tmp/etc/ssh/ssh_prng_cmds \
94 || echo "/etc/ssh/ssh_prng_cmds" >> debian/tmp/DEBIAN/conffiles 92 || echo "/etc/ssh/ssh_prng_cmds" >> debian/tmp/DEBIAN/conffiles
95 dh_shlibdeps 93 dh_shlibdeps
96ifeq ($(DEB_HOST_ARCH),hurd-i386)
97 echo "pam-depend=" >> debian/substvars
98else
99 echo "pam-depend=libpam-modules (>= 0.72-9), " >> debian/substvars
100endif
101 dh_gencontrol 94 dh_gencontrol
102 dh_md5sums 95 dh_md5sums
103 dh_builddeb 96 dh_builddeb