summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2005-06-01 17:06:42 +0000
committerColin Watson <cjwatson@debian.org>2005-06-01 17:06:42 +0000
commit34090e04a26eaf4c043c2b6bffaa1cb2e0eac1ff (patch)
tree009503d673073eeb2d214c1f79f300c7c1109bbd /debian/rules
parent9bc71eba65432b1dc61f8be4d6dbb1d1a89eebc2 (diff)
Fix DEB_HOST_ARCH_OS/DEB_HOST_GNU_SYSTEM compatibility handling.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 12 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 0398cbaa7..ce831e55d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,15 @@ endif
17 17
18VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2 | sed 's/.*://') 18VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2 | sed 's/.*://')
19DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH) 19DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
20DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null || dpkg-architecture -qDEB_HOST_GNU_SYSTEM) 20DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null)
21
22# Take account of old dpkg-architecture output.
23ifeq ($(DEB_HOST_ARCH_OS),)
24 DEB_HOST_ARCH_OS := $(subst -gnu,,$(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM))
25 ifeq ($(DEB_HOST_ARCH_OS),gnu)
26 DEB_HOST_ARCH_OS := hurd
27 endif
28endif
21 29
22CLIENT_UDEB := openssh-client-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb 30CLIENT_UDEB := openssh-client-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb
23SERVER_UDEB := openssh-server-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb 31SERVER_UDEB := openssh-server-udeb_$(VERSION)_$(DEB_HOST_ARCH).udeb
@@ -45,7 +53,7 @@ PAMDEP := libpam-runtime
45endif 53endif
46 54
47# The Hurd needs libcrypt for res_query et al. 55# The Hurd needs libcrypt for res_query et al.
48ifeq ($(DEB_HOST_ARCH_OS),gnu) 56ifeq ($(DEB_HOST_ARCH_OS),hurd)
49FORCE_LIBS := LIBS=-lcrypt 57FORCE_LIBS := LIBS=-lcrypt
50endif 58endif
51 59
@@ -134,7 +142,7 @@ install: build
134 install -m 644 -c contrib/ssh-copy-id.1 debian/openssh-client/usr/share/man/man1/ssh-copy-id.1 142 install -m 644 -c contrib/ssh-copy-id.1 debian/openssh-client/usr/share/man/man1/ssh-copy-id.1
135 install -m 644 debian/moduli.5 debian/openssh-client/usr/share/man/man5/moduli.5 143 install -m 644 debian/moduli.5 debian/openssh-client/usr/share/man/man5/moduli.5
136 144
137ifneq ($(DEB_HOST_ARCH_OS),gnu) 145ifneq ($(DEB_HOST_ARCH_OS),hurd)
138 if [ -f contrib/gnome-ssh-askpass2 ]; then \ 146 if [ -f contrib/gnome-ssh-askpass2 ]; then \
139 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass; \ 147 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass; \
140 elif [ -f contrib/gnome-ssh-askpass1 ]; then \ 148 elif [ -f contrib/gnome-ssh-askpass1 ]; then \
@@ -161,7 +169,7 @@ binary-indep: binary-ssh
161 169
162# Build architecture-dependent files here. 170# Build architecture-dependent files here.
163binary-arch: binary-openssh-client binary-openssh-server 171binary-arch: binary-openssh-client binary-openssh-server
164ifneq ($(DEB_HOST_ARCH_OS),gnu) 172ifneq ($(DEB_HOST_ARCH_OS),hurd)
165binary-arch: binary-ssh-askpass-gnome 173binary-arch: binary-ssh-askpass-gnome
166endif 174endif
167binary-arch: binary-openssh-client-udeb binary-openssh-server-udeb 175binary-arch: binary-openssh-client-udeb binary-openssh-server-udeb