summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2005-05-31 03:04:26 +0000
committerColin Watson <cjwatson@debian.org>2005-05-31 03:04:26 +0000
commit38f80c0a13d58fe27fbf5b2bae09368d3db4c09c (patch)
tree63e0ba3780758f96272fe74a284406080703ae87 /debian/rules
parent086880515569ec21401dcdc9d1b191de731b0c5e (diff)
Since ssh-keysign isn't used by default (you need to set EnableSSHKeysign
to "yes" in /etc/ssh/ssh_config), having a debconf question to ask whether it should be setuid is overkill, and the question text had got out of date anyway. Remove this question, ship ssh-keysign setuid in openssh-client.deb, and set a statoverride if the debconf question was previously set to false.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 1 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 90bd7ba9e..1538ef445 100755
--- a/debian/rules
+++ b/debian/rules
@@ -98,7 +98,6 @@ ifeq ($(PO2DEBCONF),yes)
98 # 4.1.16) depends on it), the binary-arch target will generate a 98 # 4.1.16) depends on it), the binary-arch target will generate a
99 # better version for sarge. 99 # better version for sarge.
100 echo 1 > debian/po/output 100 echo 1 > debian/po/output
101 po2debconf debian/openssh-client.templates.master > debian/openssh-client.templates
102 po2debconf debian/openssh-server.templates.master > debian/openssh-server.templates 101 po2debconf debian/openssh-server.templates.master > debian/openssh-server.templates
103 rm -f debian/po/output 102 rm -f debian/po/output
104endif 103endif
@@ -171,9 +170,6 @@ binary-openssh-client: DH_OPTIONS=-popenssh-client
171binary-openssh-client: build install 170binary-openssh-client: build install
172 dh_testdir 171 dh_testdir
173 dh_testroot 172 dh_testroot
174ifeq ($(PO2DEBCONF),yes)
175 po2debconf -e utf8 debian/openssh-client.templates.master > debian/openssh-client.templates
176endif
177 dh_installdebconf 173 dh_installdebconf
178 dh_installdocs OVERVIEW README 174 dh_installdocs OVERVIEW README
179 cat debian/copyright.head LICENCE > debian/openssh-client/usr/share/doc/openssh-client/copyright 175 cat debian/copyright.head LICENCE > debian/openssh-client/usr/share/doc/openssh-client/copyright
@@ -181,6 +177,7 @@ endif
181 dh_strip 177 dh_strip
182 dh_compress 178 dh_compress
183 dh_fixperms 179 dh_fixperms
180 chmod u+s debian/openssh-client/usr/lib/openssh/ssh-keysign
184 dh_installdeb 181 dh_installdeb
185 test ! -e debian/ssh/etc/ssh/ssh_prng_cmds \ 182 test ! -e debian/ssh/etc/ssh/ssh_prng_cmds \
186 || echo "/etc/ssh/ssh_prng_cmds" >> debian/openssh-client/DEBIAN/conffiles 183 || echo "/etc/ssh/ssh_prng_cmds" >> debian/openssh-client/DEBIAN/conffiles