summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2003-09-01 19:14:16 +0000
committerColin Watson <cjwatson@debian.org>2003-09-01 19:14:16 +0000
commit5e7b8cb37dbb1025c08b0ce4193b820dc1e66337 (patch)
treed297019b0baf31e0d3833b4abc7a5653e5df3f74 /debian/rules
parent4a4400f027c87b8b8182ecad3e821c0a0db49df0 (diff)
Debian release 3.6.1p2-2.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules26
1 files changed, 24 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index d3dcf8df9..c28dcbdfd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,6 +17,14 @@ endif
17 17
18#PKG_VER = $(shell perl -e 'print <> =~ /\((.*)\)/' debian/changelog) 18#PKG_VER = $(shell perl -e 'print <> =~ /\((.*)\)/' debian/changelog)
19 19
20ifeq (,$(wildcard /usr/bin/po2debconf))
21PO2DEBCONF := no
22MINDEBCONFVER := 0.5
23else
24PO2DEBCONF := yes
25MINDEBCONFVER := 1.2.0
26endif
27
20build: build-stamp 28build: build-stamp
21build-stamp: 29build-stamp:
22 dh_testdir 30 dh_testdir
@@ -27,7 +35,7 @@ build-stamp:
27 fi 35 fi
28 ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 \ 36 ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 \
29 --with-privsep-path=/var/run/sshd --without-rand-helper 37 --with-privsep-path=/var/run/sshd --without-rand-helper
30 $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \ 38 $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -fno-builtin-log -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \
31 SSH_KEYSIGN='/usr/lib/ssh-keysign' 39 SSH_KEYSIGN='/usr/lib/ssh-keysign'
32 # Support building on Debian 3.0 (with GNOME 1.4) and later. 40 # Support building on Debian 3.0 (with GNOME 1.4) and later.
33 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ 41 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \
@@ -46,6 +54,17 @@ clean:
46 rm -f config.log 54 rm -f config.log
47 if [ -f version.h.upstream ]; then mv version.h.upstream version.h; \ 55 if [ -f version.h.upstream ]; then mv version.h.upstream version.h; \
48 fi 56 fi
57ifeq ($(PO2DEBCONF),yes)
58 # Hack for woody compatibility. This makes sure that the
59 # debian/templates file shipped in the source package doesn't
60 # specify encodings, which woody's debconf can't handle. If building
61 # on a system with po-debconf installed (conveniently debhelper (>=
62 # 4.1.16) depends on it), the binary-arch target will generate a
63 # better version for sarge.
64 echo 1 > debian/po/output
65 po2debconf debian/templates.master > debian/templates
66 rm -f debian/po/output
67endif
49 dh_clean 68 dh_clean
50 69
51install: DH_OPTIONS= 70install: DH_OPTIONS=
@@ -88,6 +107,9 @@ binary-indep: build install
88binary-arch: build install 107binary-arch: build install
89 dh_testdir 108 dh_testdir
90 dh_testroot 109 dh_testroot
110ifeq ($(PO2DEBCONF),yes)
111 po2debconf -e utf8 debian/templates.master > debian/templates
112endif
91 dh_installdebconf 113 dh_installdebconf
92 dh_installdocs OVERVIEW README 114 dh_installdocs OVERVIEW README
93 cat debian/copyright.head LICENCE > debian/tmp/usr/share/doc/ssh/copyright 115 cat debian/copyright.head LICENCE > debian/tmp/usr/share/doc/ssh/copyright
@@ -103,7 +125,7 @@ binary-arch: build install
103 test ! -e debian/tmp/etc/ssh/ssh_prng_cmds \ 125 test ! -e debian/tmp/etc/ssh/ssh_prng_cmds \
104 || echo "/etc/ssh/ssh_prng_cmds" >> debian/tmp/DEBIAN/conffiles 126 || echo "/etc/ssh/ssh_prng_cmds" >> debian/tmp/DEBIAN/conffiles
105 dh_shlibdeps 127 dh_shlibdeps
106 dh_gencontrol 128 dh_gencontrol -- -V'debconf-depends=debconf (>= $(MINDEBCONFVER))'
107 dh_md5sums 129 dh_md5sums
108 dh_builddeb 130 dh_builddeb
109 131