summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2005-05-30 22:31:57 +0000
committerColin Watson <cjwatson@debian.org>2005-05-30 22:31:57 +0000
commit6103443e4a6e83a929fcd35d110caa0f54bc4329 (patch)
tree5450d7ed13161e958795b1a16f65d7b79a6d5c4e /debian/rules
parentc284be7080273853ba91d3df539107cd5b61ce9f (diff)
Take upstream's hint and disable the unsupported USE_POSIX_THREADS
(closes: #295757, #308868, and possibly others; may open other bugs). Use PAM password authentication to avoid #278394. In future I may provide two sets of binaries built with and without this option, since it seems I can't win.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 1 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index b5014be02..cbad70815 100755
--- a/debian/rules
+++ b/debian/rules
@@ -49,12 +49,6 @@ ifeq ($(DEB_HOST_ARCH_OS),gnu)
49FORCE_LIBS := LIBS=-lcrypt 49FORCE_LIBS := LIBS=-lcrypt
50endif 50endif
51 51
52ifeq ($(DEB_HOST_ARCH_OS),linux)
53LINK_PTHREAD := -pthread
54else
55LINK_PTHREAD := -lpthread
56endif
57
58# Change the version string to include the Debian version 52# Change the version string to include the Debian version
59SSH_EXTRAVERSION := Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//') 53SSH_EXTRAVERSION := Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//')
60 54
@@ -68,10 +62,8 @@ build-deb-stamp:
68 62
69 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). 63 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999).
70 perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h 64 perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h
71 # Supply pthread linkage for just those binaries linked to PAM.
72 perl -pi -e 's/^(LIBPAM=.*)/$$1 $(LINK_PTHREAD)/' build-deb/Makefile
73 65
74 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DUSE_POSIX_THREADS -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' 66 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign'
75 # Support building on Debian 3.0 (with GNOME 1.4) and later. 67 # Support building on Debian 3.0 (with GNOME 1.4) and later.
76 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ 68 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \
77 $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ 69 $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \