summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2004-11-12 11:37:31 +0000
committerColin Watson <cjwatson@debian.org>2004-11-12 11:37:31 +0000
commit6c6f586d90208b998f6eff99866d3179ba3fa5c8 (patch)
treeae517d3c7b0c30ac8287ec86e57d4db99c361fcc /debian/rules
parentca67136d152c5d14a6303475e445b1213ab59e39 (diff)
Merge from HEAD:
Enable threading for PAM, on Sam Hartman's advice (closes: #278394).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index dbc08d4c6..351f47785 100755
--- a/debian/rules
+++ b/debian/rules
@@ -59,9 +59,13 @@ build-deb-stamp:
59 dh_testdir 59 dh_testdir
60 mkdir -p build-deb 60 mkdir -p build-deb
61 cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper 61 cd build-deb && $(FORCE_LIBS) ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper
62
62 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999). 63 # Some 2.2 kernels have trouble with setres[ug]id() (bug #239999).
63 perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h 64 perl -pi -e 's/.*#undef (BROKEN_SETRES[UG]ID).*/#define $$1 1/' build-deb/config.h
64 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' 65 # Supply pthread linkage for just those binaries linked to PAM.
66 perl -pi -e 's/^(LIBPAM=.*)/$$1 -pthread/' build-deb/Makefile
67
68 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DUSE_POSIX_THREADS -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign'
65 # Support building on Debian 3.0 (with GNOME 1.4) and later. 69 # Support building on Debian 3.0 (with GNOME 1.4) and later.
66 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ 70 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \
67 $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ 71 $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \