summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2011-07-29 14:27:43 +0100
committerColin Watson <cjwatson@debian.org>2011-07-29 14:27:43 +0100
commit720d8309aa73b4ace915ea972203a76b65b3e782 (patch)
treea92812f0665ee59b4e28ebd929abdcd9fc03ab55 /debian/rules
parenta8c854c8ff341b1b41a7fdd9274e68d1e444b245 (diff)
Use 'dpkg-vendor --derives-from Ubuntu' to detect Ubuntu systems rather
than 'lsb_release -is' so that Ubuntu derivatives behave the same way as Ubuntu itself.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 9731c320b..eb895e0c3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -58,7 +58,7 @@ endif
58# Change the version string to include the Debian version 58# Change the version string to include the Debian version
59SSH_EXTRAVERSION := Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//') 59SSH_EXTRAVERSION := Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//')
60 60
61DISTRIBUTOR := $(shell lsb_release -is 2>/dev/null || echo Debian) 61DISTRIBUTOR := $(shell dpkg-vendor --derives-from Ubuntu 2>/dev/null && echo Ubuntu)
62ifeq ($(DISTRIBUTOR),Ubuntu) 62ifeq ($(DISTRIBUTOR),Ubuntu)
63DEFAULT_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games 63DEFAULT_PATH := /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
64else 64else