summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-01-31 00:44:13 +0000
committerColin Watson <cjwatson@debian.org>2010-01-31 00:44:13 +0000
commit73e1cc131a2052063c977e292a114028b9235e70 (patch)
tree4567600074fa9730a1289ee56aae5609d73c6a01 /debian/rules
parent339036c861447ec31ba4f5a5b0c28c9cf63e66e4 (diff)
Honour DEB_BUILD_OPTIONS=nocheck.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 9 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 5a4e4cc59..9e1350568 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,12 @@ else
14OPTFLAGS := -O0 14OPTFLAGS := -O0
15endif 15endif
16 16
17ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
18 RUN_TESTS := yes
19else
20 RUN_TESTS :=
21endif
22
17DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) 23DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) 24DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19 25
@@ -23,6 +29,7 @@ ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
23else 29else
24 confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) 30 confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
25 CC := $(DEB_HOST_GNU_TYPE)-gcc 31 CC := $(DEB_HOST_GNU_TYPE)-gcc
32 RUN_TESTS :=
26endif 33endif
27 34
28DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null) 35DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null)
@@ -123,7 +130,7 @@ build-deb-stamp:
123 130
124 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' 131 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass'
125 $(MAKE) -C contrib gnome-ssh-askpass2 CC='$(CC) $(OPTFLAGS) -g -Wall -Wl,--as-needed' 132 $(MAKE) -C contrib gnome-ssh-askpass2 CC='$(CC) $(OPTFLAGS) -g -Wall -Wl,--as-needed'
126ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE)) 133ifeq ($(RUN_TESTS),yes)
127 $(MAKE) -C debian/tests 134 $(MAKE) -C debian/tests
128endif 135endif
129 136
@@ -145,7 +152,7 @@ build-udeb-stamp:
145clean: 152clean:
146 dh_testdir 153 dh_testdir
147 rm -rf build-deb build-udeb 154 rm -rf build-deb build-udeb
148ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE)) 155ifeq ($(RUN_TESTS),yes)
149 $(MAKE) -C debian/tests clean 156 $(MAKE) -C debian/tests clean
150endif 157endif
151 $(MAKE) -C contrib clean 158 $(MAKE) -C contrib clean