summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2004-03-28 18:09:14 +0000
committerColin Watson <cjwatson@debian.org>2004-03-28 18:09:14 +0000
commita8edb34dd97fdb0bf0a56cf9d3a47ae33a53e29b (patch)
treedf2125e1ed71abbe792178de812fcb4eab4f1033 /debian/rules
parentc535b58a0ea8ee0f7396b5933ced2a96b00e70d7 (diff)
Build everything apart from contrib in a subdirectory, to allow for
multiple builds.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 9 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index e705e731a..c4c08eb0e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -42,11 +42,12 @@ endif
42# Change the version string to include the Debian version 42# Change the version string to include the Debian version
43SSH_VERSION := $(shell sed -e '/define/!d; s/.*\"\(.*\)\".*/\1/; q' <version.h) Debian $(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p') 43SSH_VERSION := $(shell sed -e '/define/!d; s/.*\"\(.*\)\".*/\1/; q' <version.h) Debian $(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p')
44 44
45build: build-stamp 45build: build-deb-stamp
46build-stamp: 46build-deb-stamp:
47 dh_testdir 47 dh_testdir
48 ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper 48 mkdir -p build-deb
49 $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' 49 cd build-deb && ../configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-privsep-path=/var/run/sshd --without-rand-helper
50 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign'
50 # Support building on Debian 3.0 (with GNOME 1.4) and later. 51 # Support building on Debian 3.0 (with GNOME 1.4) and later.
51 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ 52 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \
52 $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ 53 $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \
@@ -54,12 +55,12 @@ build-stamp:
54 $(MAKE) -C contrib gnome-ssh-askpass1 CC='gcc $(OPTFLAGS) -g -Wall'; \ 55 $(MAKE) -C contrib gnome-ssh-askpass1 CC='gcc $(OPTFLAGS) -g -Wall'; \
55 fi 56 fi
56 57
57 touch build-stamp 58 touch build-deb-stamp
58 59
59clean: 60clean:
60 dh_testdir 61 dh_testdir
61 rm -f build-stamp 62 rm -f build-deb-stamp
62 -$(MAKE) -i distclean 63 rm -rf build-deb
63 -$(MAKE) -C contrib clean 64 -$(MAKE) -C contrib clean
64 rm -f config.log 65 rm -f config.log
65ifeq ($(PO2DEBCONF),yes) 66ifeq ($(PO2DEBCONF),yes)
@@ -88,7 +89,7 @@ install: build
88 dh_installdirs 89 dh_installdirs
89 90
90 # Add here commands to install the package into debian/tmp. 91 # Add here commands to install the package into debian/tmp.
91 $(MAKE) DESTDIR=`pwd`/debian/tmp install-nokeys 92 $(MAKE) -C build-deb DESTDIR=`pwd`/debian/tmp install-nokeys
92 93
93 rm -f debian/tmp/etc/ssh/sshd_config 94 rm -f debian/tmp/etc/ssh/sshd_config
94 #Temporary hack: remove /usr/share/Ssh.bin, since we have no smartcard support anyway. 95 #Temporary hack: remove /usr/share/Ssh.bin, since we have no smartcard support anyway.