summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2004-05-20 03:05:00 +0000
committerColin Watson <cjwatson@debian.org>2004-05-20 03:05:00 +0000
commitac1235e8b4eac450a49f51c268353170d1b576f5 (patch)
tree589d957b085b5fe51b90ccc78e01b4f76aa2ae02 /debian/rules
parentec1292574a14ae5ac3805addd153cce4c5fddf48 (diff)
Restore ssh-askpass-gnome binary, lost by mistake.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 18 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index e65f47d1e..168f3f13c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -147,7 +147,8 @@ binary-indep: build install
147 # nothing to do 147 # nothing to do
148 148
149# Build architecture-dependent files here. 149# Build architecture-dependent files here.
150binary-arch: binary-ssh binary-openssh-client-udeb binary-openssh-server-udeb 150binary-arch: binary-ssh binary-ssh-askpass-gnome
151binary-arch: binary-openssh-client-udeb binary-openssh-server-udeb
151 152
152binary-ssh: DH_OPTIONS=-pssh 153binary-ssh: DH_OPTIONS=-pssh
153binary-ssh: build install 154binary-ssh: build install
@@ -185,6 +186,21 @@ endif
185 dh_md5sums 186 dh_md5sums
186 dh_builddeb 187 dh_builddeb
187 188
189binary-ssh-askpass-gnome: DH_OPTIONS=-pssh-askpass-gnome
190binary-ssh-askpass-gnome: build install
191 dh_testdir
192 dh_testroot
193 dh_installdocs
194 dh_installchangelogs ChangeLog
195 dh_strip
196 dh_compress
197 dh_fixperms
198 dh_installdeb
199 dh_shlibdeps
200 dh_gencontrol
201 dh_md5sums
202 dh_builddeb
203
188binary-openssh-client-udeb: DH_OPTIONS=-popenssh-client-udeb 204binary-openssh-client-udeb: DH_OPTIONS=-popenssh-client-udeb
189binary-openssh-client-udeb: build install 205binary-openssh-client-udeb: build install
190 dh_testdir 206 dh_testdir
@@ -214,5 +230,5 @@ binary-openssh-server-udeb: build install
214binary: binary-indep binary-arch 230binary: binary-indep binary-arch
215 231
216.PHONY: build clean binary-indep binary-arch binary install 232.PHONY: build clean binary-indep binary-arch binary install
217.PHONY: build-deb build-udeb binary-ssh 233.PHONY: build-deb build-udeb binary-ssh binary-ssh-askpass-gnome
218.PHONY: binary-openssh-client-udeb binary-openssh-server-udeb 234.PHONY: binary-openssh-client-udeb binary-openssh-server-udeb