summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2005-05-25 11:01:01 +0000
committerColin Watson <cjwatson@debian.org>2005-05-25 11:01:01 +0000
commite88de75a1a236779a10e8ccbcc51d25308be8840 (patch)
tree7495477a2a7d0cac17a9fcded020b6ea816182ef /debian/rules
parent30a0f9443782cd9d7308acd09430bf586186aa55 (diff)
parent5d05471f6657646d1d6500c7c43134462c407ee6 (diff)
Merge 4.0p1 to the trunk.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index bcb28f87f..6a3f31420 100755
--- a/debian/rules
+++ b/debian/rules
@@ -50,7 +50,7 @@ FORCE_LIBS = LIBS=-lresolv
50endif 50endif
51 51
52# Change the version string to include the Debian version 52# Change the version string to include the Debian version
53SSH_VERSION := $(shell sed -e '/define/!d; s/.*\"\(.*\)\".*/\1/; q' <version.h) Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//') 53SSH_EXTRAVERSION := Debian-$(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p' | sed -e 's/[^-]*-//')
54 54
55build: build-deb build-udeb 55build: build-deb build-udeb
56 56
@@ -65,7 +65,7 @@ build-deb-stamp:
65 # Supply pthread linkage for just those binaries linked to PAM. 65 # Supply pthread linkage for just those binaries linked to PAM.
66 perl -pi -e 's/^(LIBPAM=.*)/$$1 -pthread/' build-deb/Makefile 66 perl -pi -e 's/^(LIBPAM=.*)/$$1 -pthread/' build-deb/Makefile
67 67
68 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DUSE_POSIX_THREADS -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' 68 $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -DUSE_POSIX_THREADS -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign'
69 # Support building on Debian 3.0 (with GNOME 1.4) and later. 69 # Support building on Debian 3.0 (with GNOME 1.4) and later.
70 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ 70 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \
71 $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \ 71 $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall'; \
@@ -83,7 +83,7 @@ build-udeb-stamp:
83 # Avoid libnsl linkage. Ugh. 83 # Avoid libnsl linkage. Ugh.
84 perl -pi -e 's/ +-lnsl//' build-udeb/config.status 84 perl -pi -e 's/ +-lnsl//' build-udeb/config.status
85 cd build-udeb && ./config.status 85 cd build-udeb && ./config.status
86 $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-Os -g -Wall -DSSH_VERSION="\"$(SSH_VERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' ssh scp sftp sshd ssh-keygen 86 $(MAKE) -C build-udeb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-Os -g -Wall -DSSH_EXTRAVERSION="\" $(SSH_EXTRAVERSION)\""' SSH_KEYSIGN='/usr/lib/ssh-keysign' ssh scp sftp sshd ssh-keygen
87 touch build-udeb-stamp 87 touch build-udeb-stamp
88 88
89clean: 89clean: