summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2003-09-01 18:30:12 +0000
committerColin Watson <cjwatson@debian.org>2003-09-01 18:30:12 +0000
commitf045c69060bfdd5cf8759a5f29d7008d02e4de5b (patch)
tree2c0e43be70a2fad5141eaf1885483ae54705ec3e /debian/rules
parent7eff9df1678223e1a3427ba621f6c379386f9cce (diff)
Debian release 3.5p1-5.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 13 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 42ecea8ef..5b91fdde7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,11 +19,16 @@ build-stamp:
19 then mv version.h version.h.upstream; mv version.h.new version.h; \ 19 then mv version.h version.h.upstream; mv version.h.new version.h; \
20 else echo "Version number change failed"; exit 1; \ 20 else echo "Version number change failed"; exit 1; \
21 fi 21 fi
22 ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-ipv4-default \ 22 ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 --with-ipv4-default \
23 --with-privsep-path=/var/run/sshd --without-rand-helper 23 --with-privsep-path=/var/run/sshd --without-rand-helper
24 $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-O2 -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \ 24 $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='-O2 -g -Wall -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \
25 SSH_KEYSIGN='/usr/lib/ssh-keysign' 25 SSH_KEYSIGN='/usr/lib/ssh-keysign'
26 $(MAKE) -C contrib gnome-ssh-askpass1 CC='gcc -O2' 26 # Support building on Debian 3.0 (with GNOME 1.4) and later.
27 if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \
28 $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc -O2'; \
29 elif [ -f /usr/include/gnome-1.0/gnome.h ]; then \
30 $(MAKE) -C contrib gnome-ssh-askpass1 CC='gcc -O2'; \
31 fi
27 32
28 touch build-stamp 33 touch build-stamp
29 34
@@ -54,13 +59,18 @@ install: build
54 install -m 755 contrib/ssh-copy-id debian/tmp/usr/bin/ssh-copy-id 59 install -m 755 contrib/ssh-copy-id debian/tmp/usr/bin/ssh-copy-id
55 install -m 644 -c contrib/ssh-copy-id.1 debian/tmp/usr/share/man/man1/ssh-copy-id.1 60 install -m 644 -c contrib/ssh-copy-id.1 debian/tmp/usr/share/man/man1/ssh-copy-id.1
56 61
57 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass1 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass 62 if [ -f contrib/gnome-ssh-askpass2 ]; then \
63 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass; \
64 elif [ -f contrib/gnome-ssh-askpass1 ]; then \
65 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass1 debian/ssh-askpass-gnome/usr/lib/ssh/gnome-ssh-askpass; \
66 fi
58 install -m 644 debian/gnome-ssh-askpass.1 debian/ssh-askpass-gnome/usr/share/man/man1/gnome-ssh-askpass.1 67 install -m 644 debian/gnome-ssh-askpass.1 debian/ssh-askpass-gnome/usr/share/man/man1/gnome-ssh-askpass.1
59 68
60 install -m 755 debian/ssh-argv0 debian/tmp/usr/bin/ssh-argv0 69 install -m 755 debian/ssh-argv0 debian/tmp/usr/bin/ssh-argv0
61 install -m 644 debian/ssh-argv0.1 debian/tmp/usr/share/man/man1/ssh-argv0.1 70 install -m 644 debian/ssh-argv0.1 debian/tmp/usr/share/man/man1/ssh-argv0.1
62 71
63 install -o root -g root debian/init debian/tmp/etc/init.d/ssh 72 install -o root -g root debian/init debian/tmp/etc/init.d/ssh
73 install -o root -g root debian/ssh.default debian/tmp/etc/default/ssh
64 74
65 install -o root -g root -m 755 -d debian/tmp/var/run/sshd 75 install -o root -g root -m 755 -d debian/tmp/var/run/sshd
66 76