summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2018-01-02 00:59:19 +0000
committerColin Watson <cjwatson@debian.org>2018-01-02 00:59:19 +0000
commitf7234c24c90a60598018fbaa020f15a5ca3c82f0 (patch)
tree8abf1a25885c8691cd0ed5c084c220ab8eab87ae /debian/rules
parent182629327017f8f9d03eacdb0b621504a01189f0 (diff)
Support the "noudeb" build profile.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 9 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 734ab9c5b..225655612 100755
--- a/debian/rules
+++ b/debian/rules
@@ -132,17 +132,20 @@ override_dh_autoreconf-indep:
132 132
133override_dh_auto_configure-arch: 133override_dh_auto_configure-arch:
134 dh_auto_configure -Bdebian/build-deb -- $(confflags) 134 dh_auto_configure -Bdebian/build-deb -- $(confflags)
135ifeq ($(filter noudeb,$(DEB_BUILD_PROFILES)),)
135 dh_auto_configure -Bdebian/build-udeb -- $(confflags_udeb) 136 dh_auto_configure -Bdebian/build-udeb -- $(confflags_udeb)
136
137override_dh_auto_configure-indep:
138
139override_dh_auto_build-arch:
140 # Avoid libnsl linkage. Ugh. 137 # Avoid libnsl linkage. Ugh.
141 perl -pi -e 's/ +-lnsl//' debian/build-udeb/config.status 138 perl -pi -e 's/ +-lnsl//' debian/build-udeb/config.status
142 cd debian/build-udeb && ./config.status 139 cd debian/build-udeb && ./config.status
140endif
143 141
142override_dh_auto_configure-indep:
143
144override_dh_auto_build-arch:
144 $(MAKE) -C debian/build-deb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' 145 $(MAKE) -C debian/build-deb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass'
146ifeq ($(filter noudeb,$(DEB_BUILD_PROFILES)),)
145 $(MAKE) -C debian/build-udeb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp sftp sshd ssh-keygen 147 $(MAKE) -C debian/build-udeb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp sftp sshd ssh-keygen
148endif
146 149
147ifeq ($(filter pkg.openssh.nognome,$(DEB_BUILD_PROFILES)),) 150ifeq ($(filter pkg.openssh.nognome,$(DEB_BUILD_PROFILES)),)
148 $(MAKE) -C contrib gnome-ssh-askpass3 CC='$(CC) $(CPPFLAGS) $(CFLAGS) -Wall -Wl,--as-needed $(LDFLAGS)' PKG_CONFIG=$(PKG_CONFIG) 151 $(MAKE) -C contrib gnome-ssh-askpass3 CC='$(CC) $(CPPFLAGS) $(CFLAGS) -Wall -Wl,--as-needed $(LDFLAGS)' PKG_CONFIG=$(PKG_CONFIG)
@@ -180,8 +183,10 @@ override_dh_install-arch:
180 rm -f debian/tmp/etc/ssh/sshd_config 183 rm -f debian/tmp/etc/ssh/sshd_config
181 184
182 dh_install -Nopenssh-client-udeb -Nopenssh-server-udeb --fail-missing 185 dh_install -Nopenssh-client-udeb -Nopenssh-server-udeb --fail-missing
186ifeq ($(filter noudeb,$(DEB_BUILD_PROFILES)),)
183 dh_install -popenssh-client-udeb -popenssh-server-udeb \ 187 dh_install -popenssh-client-udeb -popenssh-server-udeb \
184 --sourcedir=debian/build-udeb 188 --sourcedir=debian/build-udeb
189endif
185 190
186 # Remove version control tags to avoid unnecessary conffile 191 # Remove version control tags to avoid unnecessary conffile
187 # resolution steps for administrators. 192 # resolution steps for administrators.