summaryrefslogtreecommitdiff
path: root/debian/tests/Makefile
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2008-05-20 19:59:07 +0000
committerColin Watson <cjwatson@debian.org>2008-05-20 19:59:07 +0000
commit2231f4c3038aefc1f77cf456b188b53fb6da4a13 (patch)
treea7bac02b6fa3cd8c2f22f9fd76c45b7f47d4ac60 /debian/tests/Makefile
parent15177d9485f496337dabadb0364c08be971c1239 (diff)
Generate two keys with the PID forced to the same value and test that
they differ, to defend against recurrences of the recent Debian OpenSSL vulnerability.
Diffstat (limited to 'debian/tests/Makefile')
-rw-r--r--debian/tests/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/tests/Makefile b/debian/tests/Makefile
new file mode 100644
index 000000000..16d9840ac
--- /dev/null
+++ b/debian/tests/Makefile
@@ -0,0 +1,11 @@
1test: getpid.so
2 ./keygen-test
3
4getpid.o: getpid.c
5 gcc -fPIC -c $< -o $@
6
7getpid.so: getpid.o
8 gcc -shared -o $@ $<
9
10clean:
11 rm -f getpid.o getpid.so key1 key1.pub key2 key2.pub