summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-04-08 09:25:21 +0100
committerColin Watson <cjwatson@debian.org>2010-04-08 09:25:21 +0100
commit4b9dad928332455162b0257d72b33554fdb799fc (patch)
treeceeca3b7acb4e3a300d1aba06313454b96916500 /debian
parent8ce3a1fcd48d46696ff88bc7297b75cb4838791c (diff)
Use dh_install more effectively.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/openssh-client-udeb.install3
-rw-r--r--debian/openssh-client.install27
-rw-r--r--debian/openssh-server-udeb.install2
-rw-r--r--debian/openssh-server.install6
-rwxr-xr-xdebian/rules22
6 files changed, 45 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index 56c3b5bbe..e271bb5a1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ openssh (1:5.4p1-2) UNRELEASED; urgency=low
6 verification (closes: #572049). 6 verification (closes: #572049).
7 * Convert to dh(1), and use dh_installdocs --link-doc. 7 * Convert to dh(1), and use dh_installdocs --link-doc.
8 * Drop lpia support, since Ubuntu no longer supports this architecture. 8 * Drop lpia support, since Ubuntu no longer supports this architecture.
9 * Use dh_install more effectively.
9 10
10 -- Colin Watson <cjwatson@debian.org> Tue, 06 Apr 2010 23:16:39 +0100 11 -- Colin Watson <cjwatson@debian.org> Tue, 06 Apr 2010 23:16:39 +0100
11 12
diff --git a/debian/openssh-client-udeb.install b/debian/openssh-client-udeb.install
new file mode 100644
index 000000000..b3891f02d
--- /dev/null
+++ b/debian/openssh-client-udeb.install
@@ -0,0 +1,3 @@
1scp usr/bin
2sftp usr/bin
3ssh usr/bin
diff --git a/debian/openssh-client.install b/debian/openssh-client.install
index aadaaf288..fd9e8feab 100644
--- a/debian/openssh-client.install
+++ b/debian/openssh-client.install
@@ -1,2 +1,29 @@
1etc/ssh/moduli
2etc/ssh/ssh_config
3usr/bin/scp
4usr/bin/sftp
5usr/bin/slogin
6usr/bin/ssh
7usr/bin/ssh-add
8usr/bin/ssh-agent
9usr/bin/ssh-keygen
10usr/bin/ssh-keyscan
11usr/bin/ssh-vulnkey
12usr/lib/openssh/ssh-keysign
13usr/lib/openssh/ssh-pkcs11-helper
14usr/share/man/man1/scp.1
15usr/share/man/man1/sftp.1
16usr/share/man/man1/slogin.1
17usr/share/man/man1/ssh-add.1
18usr/share/man/man1/ssh-agent.1
19usr/share/man/man1/ssh-keygen.1
20usr/share/man/man1/ssh-keyscan.1
21usr/share/man/man1/ssh-vulnkey.1
22usr/share/man/man1/ssh.1
23usr/share/man/man5/moduli.5
24usr/share/man/man5/ssh_config.5
25usr/share/man/man8/ssh-keysign.8
26usr/share/man/man8/ssh-pkcs11-helper.8
27
1contrib/ssh-copy-id usr/bin 28contrib/ssh-copy-id usr/bin
2debian/ssh-argv0 usr/bin 29debian/ssh-argv0 usr/bin
diff --git a/debian/openssh-server-udeb.install b/debian/openssh-server-udeb.install
new file mode 100644
index 000000000..05ccbf7af
--- /dev/null
+++ b/debian/openssh-server-udeb.install
@@ -0,0 +1,2 @@
1sshd usr/sbin
2ssh-keygen usr/bin
diff --git a/debian/openssh-server.install b/debian/openssh-server.install
new file mode 100644
index 000000000..8e04c4170
--- /dev/null
+++ b/debian/openssh-server.install
@@ -0,0 +1,6 @@
1usr/lib/openssh/sftp-server
2usr/sbin/sshd
3usr/share/man/man5/authorized_keys.5
4usr/share/man/man5/sshd_config.5
5usr/share/man/man8/sftp-server.8
6usr/share/man/man8/sshd.8
diff --git a/debian/rules b/debian/rules
index f2c24ddf9..85b916bd4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -151,30 +151,20 @@ endif
151 > debian/copyright 151 > debian/copyright
152 152
153override_dh_auto_install: 153override_dh_auto_install:
154 $(MAKE) -C build-deb DESTDIR=`pwd`/debian/openssh-client install-nokeys 154 $(MAKE) -C build-deb DESTDIR=`pwd`/debian/tmp install-nokeys
155 155
156 rm -f debian/openssh-client/etc/ssh/sshd_config 156override_dh_install:
157 rm -f debian/tmp/etc/ssh/sshd_config
157 158
158 # Split off the server. 159 dh_install -Nopenssh-client-udeb -Nopenssh-server-udeb --fail-missing
159 mv debian/openssh-client/usr/sbin/sshd debian/openssh-server/usr/sbin/ 160 dh_install -popenssh-client-udeb -popenssh-server-udeb \
160 mv debian/openssh-client/usr/lib/openssh/sftp-server debian/openssh-server/usr/lib/openssh/ 161 --sourcedir=build-udeb
161 mv debian/openssh-client/usr/share/man/man5/authorized_keys.5 debian/openssh-server/usr/share/man/man5/
162 mv debian/openssh-client/usr/share/man/man5/sshd_config.5 debian/openssh-server/usr/share/man/man5/
163 mv debian/openssh-client/usr/share/man/man8/sshd.8 debian/openssh-server/usr/share/man/man8/
164 mv debian/openssh-client/usr/share/man/man8/sftp-server.8 debian/openssh-server/usr/share/man/man8/
165 rmdir debian/openssh-client/usr/sbin debian/openssh-client/var/run/sshd
166 162
167 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass 163 install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass
168 164
169 install -o root -g root debian/openssh-server.if-up debian/openssh-server/etc/network/if-up.d/openssh-server 165 install -o root -g root debian/openssh-server.if-up debian/openssh-server/etc/network/if-up.d/openssh-server
170 install -o root -g root -m 644 debian/openssh-server.ufw.profile debian/openssh-server/etc/ufw/applications.d/openssh-server 166 install -o root -g root -m 644 debian/openssh-server.ufw.profile debian/openssh-server/etc/ufw/applications.d/openssh-server
171 167
172 install -m 755 build-udeb/ssh debian/openssh-client-udeb/usr/bin/ssh
173 install -m 755 build-udeb/scp debian/openssh-client-udeb/usr/bin/scp
174 install -m 755 build-udeb/sftp debian/openssh-client-udeb/usr/bin/sftp
175 install -m 755 build-udeb/sshd debian/openssh-server-udeb/usr/sbin/sshd
176 install -m 755 build-udeb/ssh-keygen debian/openssh-server-udeb/usr/bin/ssh-keygen
177
178 # Remove version control tags to avoid unnecessary conffile 168 # Remove version control tags to avoid unnecessary conffile
179 # resolution steps for administrators. 169 # resolution steps for administrators.
180 sed -i '/\$$OpenBSD:/d' \ 170 sed -i '/\$$OpenBSD:/d' \