summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-06-28 14:44:18 +0100
committerColin Watson <cjwatson@debian.org>2014-06-28 14:44:18 +0100
commit5c0d1a95447b14f81a69530c44db768f9a3daddd (patch)
treec58872a41b0d913dc8653a0123ed79db569809a2 /debian
parentb13ebc64d4ec4653c61d3e669eecda68dd93ec1e (diff)
Make get_config_option more robust against trailing whitespace (thanks, LaMont Jones).
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/openssh-server.config4
-rw-r--r--debian/openssh-server.postinst4
3 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 4daa26ebb..d4f7ebcb1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ openssh (1:6.6p1-6) UNRELEASED; urgency=medium
2 2
3 * Upgrade to debhelper v9. 3 * Upgrade to debhelper v9.
4 * Only use pam_keyinit on Linux architectures (closes: #747245). 4 * Only use pam_keyinit on Linux architectures (closes: #747245).
5 * Make get_config_option more robust against trailing whitespace (thanks,
6 LaMont Jones).
5 * Debconf translations: 7 * Debconf translations:
6 - Czech (thanks, Michal Šimůnek; closes: #751419). 8 - Czech (thanks, Michal Šimůnek; closes: #751419).
7 9
diff --git a/debian/openssh-server.config b/debian/openssh-server.config
index 883dbf41b..dbde2cbb0 100644
--- a/debian/openssh-server.config
+++ b/debian/openssh-server.config
@@ -10,7 +10,9 @@ get_config_option() {
10 [ -f /etc/ssh/sshd_config ] || return 10 [ -f /etc/ssh/sshd_config ] || return
11 11
12 # TODO: actually only one '=' allowed after option 12 # TODO: actually only one '=' allowed after option
13 perl -ne 'print if s/^[[:space:]]*'"$option"'[[:space:]=]+//i' \ 13 perl -lne '
14 s/[[:space:]]+/ /g; s/[[:space:]]+$//;
15 print if s/^[[:space:]]*'"$option"'[[:space:]=]+//i' \
14 /etc/ssh/sshd_config 2>/dev/null 16 /etc/ssh/sshd_config 2>/dev/null
15} 17}
16 18
diff --git a/debian/openssh-server.postinst b/debian/openssh-server.postinst
index daa0f6796..90bad6285 100644
--- a/debian/openssh-server.postinst
+++ b/debian/openssh-server.postinst
@@ -16,7 +16,9 @@ get_config_option() {
16 [ -f /etc/ssh/sshd_config ] || return 16 [ -f /etc/ssh/sshd_config ] || return
17 17
18 # TODO: actually only one '=' allowed after option 18 # TODO: actually only one '=' allowed after option
19 perl -lne 's/\s+/ /g; print if s/^\s*'"$option"'[[:space:]=]+//i' \ 19 perl -lne '
20 s/[[:space:]]+/ /g; s/[[:space:]]+$//;
21 print if s/^[[:space:]]*'"$option"'[[:space:]=]+//i' \
20 /etc/ssh/sshd_config 22 /etc/ssh/sshd_config
21} 23}
22 24