summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4a1b50331..0611b71b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.536 2013/08/04 11:48:41 dtucker Exp $ 1# $Id: configure.ac,v 1.537 2013/11/03 07:43:55 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.536 $) 18AC_REVISION($Revision: 1.537 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -3137,6 +3137,11 @@ if test "x$ac_cv_have_u_char" = "xyes" ; then
3137 AC_DEFINE([HAVE_U_CHAR], [1], [define if you have u_char data type]) 3137 AC_DEFINE([HAVE_U_CHAR], [1], [define if you have u_char data type])
3138fi 3138fi
3139 3139
3140AC_CHECK_TYPES([intmax_t, uintmax_t], , , [
3141#include <sys/types.h>
3142#include <stdint.h>
3143])
3144
3140TYPE_SOCKLEN_T 3145TYPE_SOCKLEN_T
3141 3146
3142AC_CHECK_TYPES([sig_atomic_t], , , [#include <signal.h>]) 3147AC_CHECK_TYPES([sig_atomic_t], , , [#include <signal.h>])