summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 0 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index cd6acaf9f..4d55c46fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4188,30 +4188,6 @@ AC_ARG_WITH([kerberos5],
4188AC_SUBST([GSSLIBS]) 4188AC_SUBST([GSSLIBS])
4189AC_SUBST([K5LIBS]) 4189AC_SUBST([K5LIBS])
4190 4190
4191# Check whether user wants ConsoleKit support
4192CONSOLEKIT_MSG="no"
4193LIBCK_CONNECTOR=""
4194AC_ARG_WITH(consolekit,
4195 [ --with-consolekit Enable ConsoleKit support],
4196 [ if test "x$withval" != "xno" ; then
4197 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
4198 if test "$PKGCONFIG" != "no"; then
4199 AC_MSG_CHECKING([for ck-connector])
4200 if $PKGCONFIG --exists ck-connector; then
4201 CKCON_CFLAGS=`$PKGCONFIG --cflags ck-connector`
4202 CKCON_LIBS=`$PKGCONFIG --libs ck-connector`
4203 CPPFLAGS="$CPPFLAGS $CKCON_CFLAGS"
4204 SSHDLIBS="$SSHDLIBS $CKCON_LIBS"
4205 AC_MSG_RESULT([yes])
4206 AC_DEFINE(USE_CONSOLEKIT, 1, [Define if you want ConsoleKit support.])
4207 CONSOLEKIT_MSG="yes"
4208 else
4209 AC_MSG_RESULT([no])
4210 fi
4211 fi
4212 fi ]
4213)
4214
4215# Looking for programs, paths and files 4191# Looking for programs, paths and files
4216 4192
4217PRIVSEP_PATH=/var/empty 4193PRIVSEP_PATH=/var/empty
@@ -5013,7 +4989,6 @@ echo " MD5 password support: $MD5_MSG"
5013echo " libedit support: $LIBEDIT_MSG" 4989echo " libedit support: $LIBEDIT_MSG"
5014echo " Solaris process contract support: $SPC_MSG" 4990echo " Solaris process contract support: $SPC_MSG"
5015echo " Solaris project support: $SP_MSG" 4991echo " Solaris project support: $SP_MSG"
5016echo " ConsoleKit support: $CONSOLEKIT_MSG"
5017echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 4992echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
5018echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 4993echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
5019echo " BSD Auth support: $BSD_AUTH_MSG" 4994echo " BSD Auth support: $BSD_AUTH_MSG"