summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ff199451..7b723799e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,6 +231,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
231 AC_DEFINE(BROKEN_SETREGID) 231 AC_DEFINE(BROKEN_SETREGID)
232 AC_DEFINE_UNQUOTED(BIND_8_COMPAT, 1, 232 AC_DEFINE_UNQUOTED(BIND_8_COMPAT, 1,
233 [Define if your resolver libs need this for getrrsetbyname]) 233 [Define if your resolver libs need this for getrrsetbyname])
234 AC_MSG_CHECKING(if we have the Security Authorization Session API)
235 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
236 [SessionCreate(0, 0);],
237 [ac_cv_use_security_session_api="yes"
238 AC_DEFINE(USE_SECURITY_SESSION_API, 1,
239 [platform has the Security Authorization Session API])
240 LIBS="$LIBS -framework Security"
241 AC_MSG_RESULT(yes)],
242 [ac_cv_use_security_session_api="no"
243 AC_MSG_RESULT(no)])
244 AC_MSG_CHECKING(if we have an in-memory credentials cache)
245 AC_TRY_COMPILE(
246 [#include <Kerberos/Kerberos.h>],
247 [cc_context_t c;
248 (void) cc_initialize (&c, 0, NULL, NULL);],
249 [AC_DEFINE(USE_CCAPI, 1,
250 [platform uses an in-memory credentials cache])
251 LIBS="$LIBS -framework Security"
252 AC_MSG_RESULT(yes)
253 if test "x$ac_cv_use_security_session_api" = "xno"; then
254 AC_MSG_ERROR(*** Need a security framework to use the credentials cache API ***)
255 fi],
256 [AC_MSG_RESULT(no)]
257 )
234 ;; 258 ;;
235*-*-hpux*) 259*-*-hpux*)
236 # first we define all of the options common to all HP-UX releases 260 # first we define all of the options common to all HP-UX releases