summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 128889a28..eec2b727c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4213,6 +4213,29 @@ AC_ARG_WITH([kerberos5],
4213AC_SUBST([GSSLIBS]) 4213AC_SUBST([GSSLIBS])
4214AC_SUBST([K5LIBS]) 4214AC_SUBST([K5LIBS])
4215 4215
4216# Check whether user wants systemd support
4217SYSTEMD_MSG="no"
4218AC_ARG_WITH(systemd,
4219 [ --with-systemd Enable systemd support],
4220 [ if test "x$withval" != "xno" ; then
4221 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
4222 if test "$PKGCONFIG" != "no"; then
4223 AC_MSG_CHECKING([for libsystemd])
4224 if $PKGCONFIG --exists libsystemd; then
4225 SYSTEMD_CFLAGS=`$PKGCONFIG --cflags libsystemd`
4226 SYSTEMD_LIBS=`$PKGCONFIG --libs libsystemd`
4227 CPPFLAGS="$CPPFLAGS $SYSTEMD_CFLAGS"
4228 SSHDLIBS="$SSHDLIBS $SYSTEMD_LIBS"
4229 AC_MSG_RESULT([yes])
4230 AC_DEFINE(HAVE_SYSTEMD, 1, [Define if you want systemd support.])
4231 SYSTEMD_MSG="yes"
4232 else
4233 AC_MSG_RESULT([no])
4234 fi
4235 fi
4236 fi ]
4237)
4238
4216# Looking for programs, paths and files 4239# Looking for programs, paths and files
4217 4240
4218PRIVSEP_PATH=/var/empty 4241PRIVSEP_PATH=/var/empty
@@ -5014,6 +5037,7 @@ echo " MD5 password support: $MD5_MSG"
5014echo " libedit support: $LIBEDIT_MSG" 5037echo " libedit support: $LIBEDIT_MSG"
5015echo " Solaris process contract support: $SPC_MSG" 5038echo " Solaris process contract support: $SPC_MSG"
5016echo " Solaris project support: $SP_MSG" 5039echo " Solaris project support: $SP_MSG"
5040echo " systemd support: $SYSTEMD_MSG"
5017echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 5041echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
5018echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 5042echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
5019echo " BSD Auth support: $BSD_AUTH_MSG" 5043echo " BSD Auth support: $BSD_AUTH_MSG"