summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 4 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 9d30bff61..17de2173a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.351 2006/08/18 22:38:23 djm Exp $ 1# $Id: configure.ac,v 1.352 2006/08/20 09:55:02 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.351 $) 18AC_REVISION($Revision: 1.352 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -1691,10 +1691,12 @@ AC_ARG_WITH(pam,
1691 AC_MSG_ERROR([PAM headers not found]) 1691 AC_MSG_ERROR([PAM headers not found])
1692 fi 1692 fi
1693 1693
1694 saved_LIBS="$LIBS"
1694 AC_CHECK_LIB(dl, dlopen, , ) 1695 AC_CHECK_LIB(dl, dlopen, , )
1695 AC_CHECK_LIB(pam, pam_set_item, , AC_MSG_ERROR([*** libpam missing])) 1696 AC_CHECK_LIB(pam, pam_set_item, , AC_MSG_ERROR([*** libpam missing]))
1696 AC_CHECK_FUNCS(pam_getenvlist) 1697 AC_CHECK_FUNCS(pam_getenvlist)
1697 AC_CHECK_FUNCS(pam_putenv) 1698 AC_CHECK_FUNCS(pam_putenv)
1699 LIBS="$saved_LIBS"
1698 1700
1699 PAM_MSG="yes" 1701 PAM_MSG="yes"
1700 1702
@@ -3820,14 +3822,6 @@ if test ! -z "$blibpath" ; then
3820 AC_MSG_WARN([Please check and edit blibpath in LDFLAGS in Makefile]) 3822 AC_MSG_WARN([Please check and edit blibpath in LDFLAGS in Makefile])
3821fi 3823fi
3822 3824
3823dnl remove pam and dl because they are in $LIBPAM
3824if test "$PAM_MSG" = yes ; then
3825 LIBS=`echo $LIBS | sed 's/-lpam //'`
3826fi
3827if test "$ac_cv_lib_pam_pam_set_item" = yes ; then
3828 LIBS=`echo $LIBS | sed 's/-ldl //'`
3829fi
3830
3831dnl Adding -Werror to CFLAGS early prevents configure tests from running. 3825dnl Adding -Werror to CFLAGS early prevents configure tests from running.
3832dnl Add now. 3826dnl Add now.
3833CFLAGS="$CFLAGS $werror_flags" 3827CFLAGS="$CFLAGS $werror_flags"