summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 889f50637..84bfad8c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -621,6 +621,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
621 [Use tunnel device compatibility to OpenBSD]) 621 [Use tunnel device compatibility to OpenBSD])
622 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 622 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
623 [Prepend the address family to IP tunnel traffic]) 623 [Prepend the address family to IP tunnel traffic])
624 AC_MSG_CHECKING([if we have the Security Authorization Session API])
625 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
626 [SessionCreate(0, 0);],
627 [ac_cv_use_security_session_api="yes"
628 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
629 [platform has the Security Authorization Session API])
630 LIBS="$LIBS -framework Security"
631 AC_MSG_RESULT([yes])],
632 [ac_cv_use_security_session_api="no"
633 AC_MSG_RESULT([no])])
634 AC_MSG_CHECKING([if we have an in-memory credentials cache])
635 AC_TRY_COMPILE(
636 [#include <Kerberos/Kerberos.h>],
637 [cc_context_t c;
638 (void) cc_initialize (&c, 0, NULL, NULL);],
639 [AC_DEFINE([USE_CCAPI], [1],
640 [platform uses an in-memory credentials cache])
641 LIBS="$LIBS -framework Security"
642 AC_MSG_RESULT([yes])
643 if test "x$ac_cv_use_security_session_api" = "xno"; then
644 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
645 fi],
646 [AC_MSG_RESULT([no])]
647 )
624 m4_pattern_allow([AU_IPv]) 648 m4_pattern_allow([AU_IPv])
625 AC_CHECK_DECL([AU_IPv4], [], 649 AC_CHECK_DECL([AU_IPv4], [],
626 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 650 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])