summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c8a96deb4..bb435ec1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1571,6 +1571,62 @@ else
1571 AC_MSG_RESULT([no]) 1571 AC_MSG_RESULT([no])
1572fi 1572fi
1573 1573
1574# Check whether user wants TCP wrappers support
1575TCPW_MSG="no"
1576AC_ARG_WITH([tcp-wrappers],
1577 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
1578 [
1579 if test "x$withval" != "xno" ; then
1580 saved_LIBS="$LIBS"
1581 saved_LDFLAGS="$LDFLAGS"
1582 saved_CPPFLAGS="$CPPFLAGS"
1583 if test -n "${withval}" && \
1584 test "x${withval}" != "xyes"; then
1585 if test -d "${withval}/lib"; then
1586 if test -n "${need_dash_r}"; then
1587 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
1588 else
1589 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1590 fi
1591 else
1592 if test -n "${need_dash_r}"; then
1593 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
1594 else
1595 LDFLAGS="-L${withval} ${LDFLAGS}"
1596 fi
1597 fi
1598 if test -d "${withval}/include"; then
1599 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
1600 else
1601 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1602 fi
1603 fi
1604 LIBS="-lwrap $LIBS"
1605 AC_MSG_CHECKING([for libwrap])
1606 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1607#include <sys/types.h>
1608#include <sys/socket.h>
1609#include <netinet/in.h>
1610#include <tcpd.h>
1611int deny_severity = 0, allow_severity = 0;
1612 ]], [[
1613 hosts_access(0);
1614 ]])], [
1615 AC_MSG_RESULT([yes])
1616 AC_DEFINE([LIBWRAP], [1],
1617 [Define if you want
1618 TCP Wrappers support])
1619 SSHDLIBS="$SSHDLIBS -lwrap"
1620 TCPW_MSG="yes"
1621 ], [
1622 AC_MSG_ERROR([*** libwrap missing])
1623
1624 ])
1625 LIBS="$saved_LIBS"
1626 fi
1627 ]
1628)
1629
1574# Check whether user wants to use ldns 1630# Check whether user wants to use ldns
1575LDNS_MSG="no" 1631LDNS_MSG="no"
1576AC_ARG_WITH(ldns, 1632AC_ARG_WITH(ldns,
@@ -5536,6 +5592,7 @@ echo " PAM support: $PAM_MSG"
5536echo " OSF SIA support: $SIA_MSG" 5592echo " OSF SIA support: $SIA_MSG"
5537echo " KerberosV support: $KRB5_MSG" 5593echo " KerberosV support: $KRB5_MSG"
5538echo " SELinux support: $SELINUX_MSG" 5594echo " SELinux support: $SELINUX_MSG"
5595echo " TCP Wrappers support: $TCPW_MSG"
5539echo " MD5 password support: $MD5_MSG" 5596echo " MD5 password support: $MD5_MSG"
5540echo " libedit support: $LIBEDIT_MSG" 5597echo " libedit support: $LIBEDIT_MSG"
5541echo " libldns support: $LDNS_MSG" 5598echo " libldns support: $LDNS_MSG"