summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5fdc696c8..4747ce4a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1491,6 +1491,62 @@ AC_ARG_WITH([skey],
1491 ] 1491 ]
1492) 1492)
1493 1493
1494# Check whether user wants TCP wrappers support
1495TCPW_MSG="no"
1496AC_ARG_WITH([tcp-wrappers],
1497 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
1498 [
1499 if test "x$withval" != "xno" ; then
1500 saved_LIBS="$LIBS"
1501 saved_LDFLAGS="$LDFLAGS"
1502 saved_CPPFLAGS="$CPPFLAGS"
1503 if test -n "${withval}" && \
1504 test "x${withval}" != "xyes"; then
1505 if test -d "${withval}/lib"; then
1506 if test -n "${need_dash_r}"; then
1507 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
1508 else
1509 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1510 fi
1511 else
1512 if test -n "${need_dash_r}"; then
1513 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
1514 else
1515 LDFLAGS="-L${withval} ${LDFLAGS}"
1516 fi
1517 fi
1518 if test -d "${withval}/include"; then
1519 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
1520 else
1521 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1522 fi
1523 fi
1524 LIBS="-lwrap $LIBS"
1525 AC_MSG_CHECKING([for libwrap])
1526 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1527#include <sys/types.h>
1528#include <sys/socket.h>
1529#include <netinet/in.h>
1530#include <tcpd.h>
1531int deny_severity = 0, allow_severity = 0;
1532 ]], [[
1533 hosts_access(0);
1534 ]])], [
1535 AC_MSG_RESULT([yes])
1536 AC_DEFINE([LIBWRAP], [1],
1537 [Define if you want
1538 TCP Wrappers support])
1539 SSHDLIBS="$SSHDLIBS -lwrap"
1540 TCPW_MSG="yes"
1541 ], [
1542 AC_MSG_ERROR([*** libwrap missing])
1543
1544 ])
1545 LIBS="$saved_LIBS"
1546 fi
1547 ]
1548)
1549
1494# Check whether user wants to use ldns 1550# Check whether user wants to use ldns
1495LDNS_MSG="no" 1551LDNS_MSG="no"
1496AC_ARG_WITH(ldns, 1552AC_ARG_WITH(ldns,
@@ -5105,6 +5161,7 @@ echo " KerberosV support: $KRB5_MSG"
5105echo " SELinux support: $SELINUX_MSG" 5161echo " SELinux support: $SELINUX_MSG"
5106echo " Smartcard support: $SCARD_MSG" 5162echo " Smartcard support: $SCARD_MSG"
5107echo " S/KEY support: $SKEY_MSG" 5163echo " S/KEY support: $SKEY_MSG"
5164echo " TCP Wrappers support: $TCPW_MSG"
5108echo " MD5 password support: $MD5_MSG" 5165echo " MD5 password support: $MD5_MSG"
5109echo " libedit support: $LIBEDIT_MSG" 5166echo " libedit support: $LIBEDIT_MSG"
5110echo " Solaris process contract support: $SPC_MSG" 5167echo " Solaris process contract support: $SPC_MSG"