summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 24 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 637e7b536..d267ba2b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.451 2010/08/16 03:15:23 dtucker Exp $ 1# $Id: configure.ac,v 1.452 2010/09/10 01:39:27 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.451 $) 18AC_REVISION($Revision: 1.452 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -2158,6 +2158,28 @@ fi
2158# Search for SHA256 support in libc and/or OpenSSL 2158# Search for SHA256 support in libc and/or OpenSSL
2159AC_CHECK_FUNCS(SHA256_Update EVP_sha256) 2159AC_CHECK_FUNCS(SHA256_Update EVP_sha256)
2160 2160
2161# Check complete ECC support in OpenSSL
2162AC_MSG_CHECKING([whether OpenSSL has complete ECC support])
2163AC_LINK_IFELSE(
2164 [AC_LANG_SOURCE([[
2165#include <openssl/ec.h>
2166#include <openssl/evp.h>
2167#include <openssl/objects.h>
2168int main(void) {
2169 EC_KEY *e = EC_KEY_new_by_curve_name(NID_secp521r1);
2170 const EVP_MD *m = EVP_sha512(); /* We need this too */
2171}
2172 ]])],
2173 [
2174 AC_MSG_RESULT(yes)
2175 AC_DEFINE(OPENSSL_HAS_ECC, 1,
2176 [libcrypto includes complete ECC support])
2177 ],
2178 [
2179 AC_MSG_RESULT(no)
2180 ]
2181)
2182
2161saved_LIBS="$LIBS" 2183saved_LIBS="$LIBS"
2162AC_CHECK_LIB(iaf, ia_openinfo, [ 2184AC_CHECK_LIB(iaf, ia_openinfo, [
2163 LIBS="$LIBS -liaf" 2185 LIBS="$LIBS -liaf"