summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 12 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index da919a636..a704fc7ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.495 2012/07/03 22:50:10 dtucker Exp $ 1# $Id: configure.ac,v 1.496 2012/07/06 01:49:29 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.495 $) 18AC_REVISION($Revision: 1.496 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -4005,13 +4005,16 @@ otherwise scp will not work.])
4005 [ user_path="/usr/bin:/bin:/usr/sbin:/sbin" ] 4005 [ user_path="/usr/bin:/bin:/usr/sbin:/sbin" ]
4006 ) 4006 )
4007# make sure $bindir is in USER_PATH so scp will work 4007# make sure $bindir is in USER_PATH so scp will work
4008 t_bindir=`eval echo ${bindir}` 4008 t_bindir="${bindir}"
4009 case $t_bindir in 4009 while echo "${t_bindir}" | egrep '\$\{|NONE/' >/dev/null 2>&1; do
4010 NONE/*) t_bindir=`echo $t_bindir | sed "s~NONE~$prefix~"` ;; 4010 t_bindir=`eval echo ${t_bindir}`
4011 esac 4011 case $t_bindir in
4012 case $t_bindir in 4012 NONE/*) t_bindir=`echo $t_bindir | sed "s~NONE~$prefix~"` ;;
4013 NONE/*) t_bindir=`echo $t_bindir | sed "s~NONE~$ac_default_prefix~"` ;; 4013 esac
4014 esac 4014 case $t_bindir in
4015 NONE/*) t_bindir=`echo $t_bindir | sed "s~NONE~$ac_default_prefix~"` ;;
4016 esac
4017 done
4015 echo $user_path | grep ":$t_bindir" > /dev/null 2>&1 4018 echo $user_path | grep ":$t_bindir" > /dev/null 2>&1
4016 if test $? -ne 0 ; then 4019 if test $? -ne 0 ; then
4017 echo $user_path | grep "^$t_bindir" > /dev/null 2>&1 4020 echo $user_path | grep "^$t_bindir" > /dev/null 2>&1