summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 216a9fdab..5f606ea12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1440,6 +1440,62 @@ AC_ARG_WITH([skey],
1440 ] 1440 ]
1441) 1441)
1442 1442
1443# Check whether user wants TCP wrappers support
1444TCPW_MSG="no"
1445AC_ARG_WITH([tcp-wrappers],
1446 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
1447 [
1448 if test "x$withval" != "xno" ; then
1449 saved_LIBS="$LIBS"
1450 saved_LDFLAGS="$LDFLAGS"
1451 saved_CPPFLAGS="$CPPFLAGS"
1452 if test -n "${withval}" && \
1453 test "x${withval}" != "xyes"; then
1454 if test -d "${withval}/lib"; then
1455 if test -n "${need_dash_r}"; then
1456 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
1457 else
1458 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1459 fi
1460 else
1461 if test -n "${need_dash_r}"; then
1462 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
1463 else
1464 LDFLAGS="-L${withval} ${LDFLAGS}"
1465 fi
1466 fi
1467 if test -d "${withval}/include"; then
1468 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
1469 else
1470 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1471 fi
1472 fi
1473 LIBS="-lwrap $LIBS"
1474 AC_MSG_CHECKING([for libwrap])
1475 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1476#include <sys/types.h>
1477#include <sys/socket.h>
1478#include <netinet/in.h>
1479#include <tcpd.h>
1480int deny_severity = 0, allow_severity = 0;
1481 ]], [[
1482 hosts_access(0);
1483 ]])], [
1484 AC_MSG_RESULT([yes])
1485 AC_DEFINE([LIBWRAP], [1],
1486 [Define if you want
1487 TCP Wrappers support])
1488 SSHDLIBS="$SSHDLIBS -lwrap"
1489 TCPW_MSG="yes"
1490 ], [
1491 AC_MSG_ERROR([*** libwrap missing])
1492
1493 ])
1494 LIBS="$saved_LIBS"
1495 fi
1496 ]
1497)
1498
1443# Check whether user wants to use ldns 1499# Check whether user wants to use ldns
1444LDNS_MSG="no" 1500LDNS_MSG="no"
1445AC_ARG_WITH(ldns, 1501AC_ARG_WITH(ldns,
@@ -4920,6 +4976,7 @@ echo " KerberosV support: $KRB5_MSG"
4920echo " SELinux support: $SELINUX_MSG" 4976echo " SELinux support: $SELINUX_MSG"
4921echo " Smartcard support: $SCARD_MSG" 4977echo " Smartcard support: $SCARD_MSG"
4922echo " S/KEY support: $SKEY_MSG" 4978echo " S/KEY support: $SKEY_MSG"
4979echo " TCP Wrappers support: $TCPW_MSG"
4923echo " MD5 password support: $MD5_MSG" 4980echo " MD5 password support: $MD5_MSG"
4924echo " libedit support: $LIBEDIT_MSG" 4981echo " libedit support: $LIBEDIT_MSG"
4925echo " Solaris process contract support: $SPC_MSG" 4982echo " Solaris process contract support: $SPC_MSG"