summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 31972cf9b..e31147c24 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.539 2013/11/07 11:33:48 dtucker Exp $ 1# $Id: configure.ac,v 1.540 2013/11/08 13:17:41 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.539 $) 18AC_REVISION($Revision: 1.540 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -563,6 +563,7 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
563 ;; 563 ;;
564*-*-dragonfly*) 564*-*-dragonfly*)
565 SSHDLIBS="$SSHDLIBS -lcrypt" 565 SSHDLIBS="$SSHDLIBS -lcrypt"
566 TEST_MALLOC_OPTIONS="AFGJPRX"
566 ;; 567 ;;
567*-*-haiku*) 568*-*-haiku*)
568 LIBS="$LIBS -lbsd " 569 LIBS="$LIBS -lbsd "
@@ -728,6 +729,7 @@ mips-sony-bsd|mips-sony-newsos4)
728 AC_DEFINE([SSH_TUN_NO_L2], [1], [No layer 2 tunnel support])) 729 AC_DEFINE([SSH_TUN_NO_L2], [1], [No layer 2 tunnel support]))
729 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 730 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
730 [Prepend the address family to IP tunnel traffic]) 731 [Prepend the address family to IP tunnel traffic])
732 TEST_MALLOC_OPTIONS="AJRX"
731 ;; 733 ;;
732*-*-freebsd*) 734*-*-freebsd*)
733 check_for_libcrypt_later=1 735 check_for_libcrypt_later=1
@@ -736,7 +738,8 @@ mips-sony-bsd|mips-sony-newsos4)
736 AC_CHECK_HEADER([net/if_tap.h], , 738 AC_CHECK_HEADER([net/if_tap.h], ,
737 AC_DEFINE([SSH_TUN_NO_L2], [1], [No layer 2 tunnel support])) 739 AC_DEFINE([SSH_TUN_NO_L2], [1], [No layer 2 tunnel support]))
738 AC_DEFINE([BROKEN_GLOB], [1], [FreeBSD glob does not do what we need]) 740 AC_DEFINE([BROKEN_GLOB], [1], [FreeBSD glob does not do what we need])
739 AC_DEFINE([BROKEN_STRNVIS], [1], [FreeBSD strnvis does not do what we need]) 741 AC_DEFINE([BROKEN_STRNVIS], [1], [FreeBSD strnvis does not do what we need])
742 TEST_MALLOC_OPTIONS="AJRX"
740 ;; 743 ;;
741*-*-bsdi*) 744*-*-bsdi*)
742 AC_DEFINE([SETEUID_BREAKS_SETUID]) 745 AC_DEFINE([SETEUID_BREAKS_SETUID])
@@ -759,6 +762,7 @@ mips-sony-bsd|mips-sony-newsos4)
759 AC_DEFINE([SSH_TUN_OPENBSD], [1], [Open tunnel devices the OpenBSD way]) 762 AC_DEFINE([SSH_TUN_OPENBSD], [1], [Open tunnel devices the OpenBSD way])
760 AC_DEFINE([SYSLOG_R_SAFE_IN_SIGHAND], [1], 763 AC_DEFINE([SYSLOG_R_SAFE_IN_SIGHAND], [1],
761 [syslog_r function is safe to use in in a signal handler]) 764 [syslog_r function is safe to use in in a signal handler])
765 TEST_MALLOC_OPTIONS="AFGJPRX"
762 ;; 766 ;;
763*-*-solaris*) 767*-*-solaris*)
764 if test "x$withval" != "xno" ; then 768 if test "x$withval" != "xno" ; then
@@ -4564,6 +4568,7 @@ else
4564fi 4568fi
4565AC_CHECK_DECL([BROKEN_GETADDRINFO], [TEST_SSH_IPV6=no]) 4569AC_CHECK_DECL([BROKEN_GETADDRINFO], [TEST_SSH_IPV6=no])
4566AC_SUBST([TEST_SSH_IPV6], [$TEST_SSH_IPV6]) 4570AC_SUBST([TEST_SSH_IPV6], [$TEST_SSH_IPV6])
4571AC_SUBST([TEST_MALLOC_OPTIONS], [$TEST_MALLOC_OPTIONS])
4567AC_SUBST([UNSUPPORTED_ALGORITHMS], [$unsupported_algorithms]) 4572AC_SUBST([UNSUPPORTED_ALGORITHMS], [$unsupported_algorithms])
4568 4573
4569AC_EXEEXT 4574AC_EXEEXT