summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5f606ea12..f7ce777a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4180,6 +4180,30 @@ AC_ARG_WITH([kerberos5],
4180AC_SUBST([GSSLIBS]) 4180AC_SUBST([GSSLIBS])
4181AC_SUBST([K5LIBS]) 4181AC_SUBST([K5LIBS])
4182 4182
4183# Check whether user wants ConsoleKit support
4184CONSOLEKIT_MSG="no"
4185LIBCK_CONNECTOR=""
4186AC_ARG_WITH(consolekit,
4187 [ --with-consolekit Enable ConsoleKit support],
4188 [ if test "x$withval" != "xno" ; then
4189 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
4190 if test "$PKGCONFIG" != "no"; then
4191 AC_MSG_CHECKING([for ck-connector])
4192 if $PKGCONFIG --exists ck-connector; then
4193 CKCON_CFLAGS=`$PKGCONFIG --cflags ck-connector`
4194 CKCON_LIBS=`$PKGCONFIG --libs ck-connector`
4195 CPPFLAGS="$CPPFLAGS $CKCON_CFLAGS"
4196 SSHDLIBS="$SSHDLIBS $CKCON_LIBS"
4197 AC_MSG_RESULT([yes])
4198 AC_DEFINE(USE_CONSOLEKIT, 1, [Define if you want ConsoleKit support.])
4199 CONSOLEKIT_MSG="yes"
4200 else
4201 AC_MSG_RESULT([no])
4202 fi
4203 fi
4204 fi ]
4205)
4206
4183# Looking for programs, paths and files 4207# Looking for programs, paths and files
4184 4208
4185PRIVSEP_PATH=/var/empty 4209PRIVSEP_PATH=/var/empty
@@ -4981,6 +5005,7 @@ echo " MD5 password support: $MD5_MSG"
4981echo " libedit support: $LIBEDIT_MSG" 5005echo " libedit support: $LIBEDIT_MSG"
4982echo " Solaris process contract support: $SPC_MSG" 5006echo " Solaris process contract support: $SPC_MSG"
4983echo " Solaris project support: $SP_MSG" 5007echo " Solaris project support: $SP_MSG"
5008echo " ConsoleKit support: $CONSOLEKIT_MSG"
4984echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 5009echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
4985echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 5010echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
4986echo " BSD Auth support: $BSD_AUTH_MSG" 5011echo " BSD Auth support: $BSD_AUTH_MSG"