summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 637b14e40..1b8aa5e1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.56 2002/05/11 20:17:44 tim Exp $ 1# $Id: configure.ac,v 1.57 2002/05/13 00:48:58 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -2011,6 +2011,19 @@ if test "$USES_LOGIN_CONF" != "yes" ; then
2011 AC_SUBST(user_path) 2011 AC_SUBST(user_path)
2012fi 2012fi
2013 2013
2014# Set superuser path separately to user path
2015MD5_MSG="no"
2016AC_ARG_WITH(superuser-path,
2017 [ --with-superuser-path= Specify different path for super-user],
2018 [
2019 if test "x$withval" != "xno" ; then
2020 AC_DEFINE_UNQUOTED(SUPERUSER_PATH, "$withval")
2021 superuser_path=$withval
2022 fi
2023 ]
2024)
2025
2026
2014# Whether to force IPv4 by default (needed on broken glibc Linux) 2027# Whether to force IPv4 by default (needed on broken glibc Linux)
2015IPV4_HACK_MSG="no" 2028IPV4_HACK_MSG="no"
2016AC_ARG_WITH(ipv4-default, 2029AC_ARG_WITH(ipv4-default,
@@ -2351,6 +2364,7 @@ E=`eval echo ${libexecdir}/ssh-askpass` ; E=`eval echo ${E}`
2351F=`eval echo ${mandir}/${mansubdir}X` ; F=`eval echo ${F}` 2364F=`eval echo ${mandir}/${mansubdir}X` ; F=`eval echo ${F}`
2352G=`eval echo ${piddir}` ; G=`eval echo ${G}` 2365G=`eval echo ${piddir}` ; G=`eval echo ${G}`
2353H=`eval echo ${user_path}` ; H=`eval echo ${H}` 2366H=`eval echo ${user_path}` ; H=`eval echo ${H}`
2367I=`eval echo ${superuser_path}` ; I=`eval echo ${I}`
2354 2368
2355echo "" 2369echo ""
2356echo "OpenSSH has been configured with the following options:" 2370echo "OpenSSH has been configured with the following options:"
@@ -2365,6 +2379,9 @@ echo " At runtime, sshd will use the path defined in /etc/login.conf"
2365else 2379else
2366echo " sshd default user PATH: $H" 2380echo " sshd default user PATH: $H"
2367fi 2381fi
2382if test ! -z "$superuser_path" ; then
2383echo " sshd superuser user PATH: $I"
2384fi
2368echo " Manpage format: $MANTYPE" 2385echo " Manpage format: $MANTYPE"
2369echo " PAM support: ${PAM_MSG}" 2386echo " PAM support: ${PAM_MSG}"
2370echo " KerberosIV support: $KRB4_MSG" 2387echo " KerberosIV support: $KRB4_MSG"