summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 25 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 850205cc7..76ac0e06c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.217 2004/05/13 01:56:17 dtucker Exp $ 1# $Id: configure.ac,v 1.218 2004/05/23 04:09:40 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -926,6 +926,20 @@ int main(void){char b[5];snprintf(b,5,"123456789");exit(b[4]!='\0');}
926 ) 926 )
927fi 927fi
928 928
929# Check for missing getpeereid (or equiv) support
930NO_PEERCHECK=""
931if test "x$ac_cv_func_getpeereid" != "xyes" ; then
932 AC_MSG_CHECKING([whether system supports SO_PEERCRED getsockopt])
933 AC_TRY_COMPILE(
934 [#include <sys/types.h>
935 #include <sys/socket.h>],
936 [int i = SO_PEERCRED;],
937 [AC_MSG_RESULT(yes)],
938 [AC_MSG_RESULT(no)
939 NO_PEERCHECK=1]
940 )
941fi
942
929dnl see whether mkstemp() requires XXXXXX 943dnl see whether mkstemp() requires XXXXXX
930if test "x$ac_cv_func_mkdtemp" = "xyes" ; then 944if test "x$ac_cv_func_mkdtemp" = "xyes" ; then
931AC_MSG_CHECKING([for (overly) strict mkstemp]) 945AC_MSG_CHECKING([for (overly) strict mkstemp])
@@ -2975,3 +2989,13 @@ if test ! -z "$RAND_HELPER_CMDHASH" ; then
2975 echo "" 2989 echo ""
2976fi 2990fi
2977 2991
2992if test ! -z "$NO_PEERCHECK" ; then
2993 echo "WARNING: the operating system that you are using does not "
2994 echo "appear to support either the getpeereid() API nor the "
2995 echo "SO_PEERCRED getsockopt() option. These facilities are used to "
2996 echo "enforce security checks to prevent unauthorised connections to "
2997 echo "ssh-agent. Their absence increases the risk that a malicious "
2998 echo "user can connect to your agent. "
2999 echo ""
3000fi
3001