summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7b723799e..aa12fabce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2986,15 +2986,25 @@ int main()
2986 2986
2987# Check whether user wants SELinux support 2987# Check whether user wants SELinux support
2988SELINUX_MSG="no" 2988SELINUX_MSG="no"
2989LIBSELINUX=""
2989AC_ARG_WITH(selinux, 2990AC_ARG_WITH(selinux,
2990 [ --with-selinux Enable SELinux support], 2991 [ --with-selinux[[=LIBSELINUX-PATH]] Enable SELinux support],
2991 [ if test "x$withval" != "xno" ; then 2992 [ if test "x$withval" != "xno" ; then
2992 AC_DEFINE(WITH_SELINUX, 1, [Define if you want SELinux support.]) 2993 if test "x$withval" != "xyes"; then
2994 CPPFLAGS="$CPPFLAGS -I${withval}/include"
2995 if test -n "${need_dash_r}"; then
2996 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
2997 else
2998 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
2999 fi
3000 fi
3001 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.])
2993 SELINUX_MSG="yes" 3002 SELINUX_MSG="yes"
2994 AC_CHECK_HEADERS(selinux/selinux.h) 3003 AC_CHECK_HEADERS(selinux/selinux.h)
2995 LIBS="$LIBS -lselinux" 3004 LIBSELINUX="-lselinux"
2996 fi 3005 fi
2997 ]) 3006 ])
3007AC_SUBST(LIBSELINUX)
2998 3008
2999# Check whether user wants Kerberos 5 support 3009# Check whether user wants Kerberos 5 support
3000KRB5_MSG="no" 3010KRB5_MSG="no"