summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 894ec3b7b..f822fb31c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1510,6 +1510,62 @@ AC_ARG_WITH([skey],
1510 ] 1510 ]
1511) 1511)
1512 1512
1513# Check whether user wants TCP wrappers support
1514TCPW_MSG="no"
1515AC_ARG_WITH([tcp-wrappers],
1516 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
1517 [
1518 if test "x$withval" != "xno" ; then
1519 saved_LIBS="$LIBS"
1520 saved_LDFLAGS="$LDFLAGS"
1521 saved_CPPFLAGS="$CPPFLAGS"
1522 if test -n "${withval}" && \
1523 test "x${withval}" != "xyes"; then
1524 if test -d "${withval}/lib"; then
1525 if test -n "${need_dash_r}"; then
1526 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
1527 else
1528 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1529 fi
1530 else
1531 if test -n "${need_dash_r}"; then
1532 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
1533 else
1534 LDFLAGS="-L${withval} ${LDFLAGS}"
1535 fi
1536 fi
1537 if test -d "${withval}/include"; then
1538 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
1539 else
1540 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1541 fi
1542 fi
1543 LIBS="-lwrap $LIBS"
1544 AC_MSG_CHECKING([for libwrap])
1545 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1546#include <sys/types.h>
1547#include <sys/socket.h>
1548#include <netinet/in.h>
1549#include <tcpd.h>
1550int deny_severity = 0, allow_severity = 0;
1551 ]], [[
1552 hosts_access(0);
1553 ]])], [
1554 AC_MSG_RESULT([yes])
1555 AC_DEFINE([LIBWRAP], [1],
1556 [Define if you want
1557 TCP Wrappers support])
1558 SSHDLIBS="$SSHDLIBS -lwrap"
1559 TCPW_MSG="yes"
1560 ], [
1561 AC_MSG_ERROR([*** libwrap missing])
1562
1563 ])
1564 LIBS="$saved_LIBS"
1565 fi
1566 ]
1567)
1568
1513# Check whether user wants to use ldns 1569# Check whether user wants to use ldns
1514LDNS_MSG="no" 1570LDNS_MSG="no"
1515AC_ARG_WITH(ldns, 1571AC_ARG_WITH(ldns,
@@ -5059,6 +5115,7 @@ echo " KerberosV support: $KRB5_MSG"
5059echo " SELinux support: $SELINUX_MSG" 5115echo " SELinux support: $SELINUX_MSG"
5060echo " Smartcard support: $SCARD_MSG" 5116echo " Smartcard support: $SCARD_MSG"
5061echo " S/KEY support: $SKEY_MSG" 5117echo " S/KEY support: $SKEY_MSG"
5118echo " TCP Wrappers support: $TCPW_MSG"
5062echo " MD5 password support: $MD5_MSG" 5119echo " MD5 password support: $MD5_MSG"
5063echo " libedit support: $LIBEDIT_MSG" 5120echo " libedit support: $LIBEDIT_MSG"
5064echo " Solaris process contract support: $SPC_MSG" 5121echo " Solaris process contract support: $SPC_MSG"