summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 84bfad8c5..3b30736b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1503,6 +1503,62 @@ AC_ARG_WITH([skey],
1503 ] 1503 ]
1504) 1504)
1505 1505
1506# Check whether user wants TCP wrappers support
1507TCPW_MSG="no"
1508AC_ARG_WITH([tcp-wrappers],
1509 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
1510 [
1511 if test "x$withval" != "xno" ; then
1512 saved_LIBS="$LIBS"
1513 saved_LDFLAGS="$LDFLAGS"
1514 saved_CPPFLAGS="$CPPFLAGS"
1515 if test -n "${withval}" && \
1516 test "x${withval}" != "xyes"; then
1517 if test -d "${withval}/lib"; then
1518 if test -n "${need_dash_r}"; then
1519 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
1520 else
1521 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1522 fi
1523 else
1524 if test -n "${need_dash_r}"; then
1525 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
1526 else
1527 LDFLAGS="-L${withval} ${LDFLAGS}"
1528 fi
1529 fi
1530 if test -d "${withval}/include"; then
1531 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
1532 else
1533 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1534 fi
1535 fi
1536 LIBS="-lwrap $LIBS"
1537 AC_MSG_CHECKING([for libwrap])
1538 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1539#include <sys/types.h>
1540#include <sys/socket.h>
1541#include <netinet/in.h>
1542#include <tcpd.h>
1543int deny_severity = 0, allow_severity = 0;
1544 ]], [[
1545 hosts_access(0);
1546 ]])], [
1547 AC_MSG_RESULT([yes])
1548 AC_DEFINE([LIBWRAP], [1],
1549 [Define if you want
1550 TCP Wrappers support])
1551 SSHDLIBS="$SSHDLIBS -lwrap"
1552 TCPW_MSG="yes"
1553 ], [
1554 AC_MSG_ERROR([*** libwrap missing])
1555
1556 ])
1557 LIBS="$saved_LIBS"
1558 fi
1559 ]
1560)
1561
1506# Check whether user wants to use ldns 1562# Check whether user wants to use ldns
1507LDNS_MSG="no" 1563LDNS_MSG="no"
1508AC_ARG_WITH(ldns, 1564AC_ARG_WITH(ldns,
@@ -5133,6 +5189,7 @@ echo " KerberosV support: $KRB5_MSG"
5133echo " SELinux support: $SELINUX_MSG" 5189echo " SELinux support: $SELINUX_MSG"
5134echo " Smartcard support: $SCARD_MSG" 5190echo " Smartcard support: $SCARD_MSG"
5135echo " S/KEY support: $SKEY_MSG" 5191echo " S/KEY support: $SKEY_MSG"
5192echo " TCP Wrappers support: $TCPW_MSG"
5136echo " MD5 password support: $MD5_MSG" 5193echo " MD5 password support: $MD5_MSG"
5137echo " libedit support: $LIBEDIT_MSG" 5194echo " libedit support: $LIBEDIT_MSG"
5138echo " libldns support: $LDNS_MSG" 5195echo " libldns support: $LDNS_MSG"