summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 44ff46ab1..d29091e9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.69 2002/06/24 16:26:49 stevesk Exp $ 1# $Id: configure.ac,v 1.70 2002/06/25 00:24:48 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -906,16 +906,17 @@ AC_ARG_WITH(entropy-timeout,
906) 906)
907AC_DEFINE_UNQUOTED(ENTROPY_TIMEOUT_MSEC, $entropy_timeout) 907AC_DEFINE_UNQUOTED(ENTROPY_TIMEOUT_MSEC, $entropy_timeout)
908 908
909ssh_privsep_user=sshd 909SSH_PRIVSEP_USER=sshd
910AC_ARG_WITH(privsep-user, 910AC_ARG_WITH(privsep-user,
911 [ --with-privsep-user=user Specify non-privileged user for privilege separation], 911 [ --with-privsep-user=user Specify non-privileged user for privilege separation],
912 [ 912 [
913 if test -n "$withval"; then 913 if test -n "$withval"; then
914 ssh_privsep_user=$withval 914 SSH_PRIVSEP_USER=$withval
915 fi 915 fi
916 ] 916 ]
917) 917)
918AC_DEFINE_UNQUOTED(SSH_PRIVSEP_USER, "$ssh_privsep_user") 918AC_DEFINE_UNQUOTED(SSH_PRIVSEP_USER, "$SSH_PRIVSEP_USER")
919AC_SUBST(SSH_PRIVSEP_USER)
919 920
920# We do this little dance with the search path to insure 921# We do this little dance with the search path to insure
921# that programs that we select for use by installed programs 922# that programs that we select for use by installed programs