summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c2878e3d4..ead34acf5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -623,6 +623,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
623 [Use tunnel device compatibility to OpenBSD]) 623 [Use tunnel device compatibility to OpenBSD])
624 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 624 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
625 [Prepend the address family to IP tunnel traffic]) 625 [Prepend the address family to IP tunnel traffic])
626 AC_MSG_CHECKING([if we have the Security Authorization Session API])
627 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
628 [SessionCreate(0, 0);],
629 [ac_cv_use_security_session_api="yes"
630 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
631 [platform has the Security Authorization Session API])
632 LIBS="$LIBS -framework Security"
633 AC_MSG_RESULT([yes])],
634 [ac_cv_use_security_session_api="no"
635 AC_MSG_RESULT([no])])
636 AC_MSG_CHECKING([if we have an in-memory credentials cache])
637 AC_TRY_COMPILE(
638 [#include <Kerberos/Kerberos.h>],
639 [cc_context_t c;
640 (void) cc_initialize (&c, 0, NULL, NULL);],
641 [AC_DEFINE([USE_CCAPI], [1],
642 [platform uses an in-memory credentials cache])
643 LIBS="$LIBS -framework Security"
644 AC_MSG_RESULT([yes])
645 if test "x$ac_cv_use_security_session_api" = "xno"; then
646 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
647 fi],
648 [AC_MSG_RESULT([no])]
649 )
626 m4_pattern_allow([AU_IPv]) 650 m4_pattern_allow([AU_IPv])
627 AC_CHECK_DECL([AU_IPv4], [], 651 AC_CHECK_DECL([AU_IPv4], [],
628 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 652 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])