summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1fb3056e6..f94f6c848 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.79 2002/07/14 20:36:50 tim Exp $ 1# $Id: configure.ac,v 1.80 2002/07/18 02:20:08 tim Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -1818,7 +1818,12 @@ AC_ARG_WITH(xauth,
1818 fi 1818 fi
1819 ], 1819 ],
1820 [ 1820 [
1821 AC_PATH_PROG(xauth_path, xauth,,$PATH:/usr/X/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/openwin/bin) 1821 TestPath="$PATH"
1822 TestPath="${TestPath}${PATH_SEPARATOR}/usr/X/bin"
1823 TestPath="${TestPath}${PATH_SEPARATOR}/usr/bin/X11"
1824 TestPath="${TestPath}${PATH_SEPARATOR}/usr/X11R6/bin"
1825 TestPath="${TestPath}${PATH_SEPARATOR}/usr/openwin/bin"
1826 AC_PATH_PROG(xauth_path, xauth, , $TestPath)
1822 if (test ! -z "$xauth_path" && test -x "/usr/openwin/bin/xauth") ; then 1827 if (test ! -z "$xauth_path" && test -x "/usr/openwin/bin/xauth") ; then
1823 xauth_path="/usr/openwin/bin/xauth" 1828 xauth_path="/usr/openwin/bin/xauth"
1824 fi 1829 fi
@@ -1872,7 +1877,8 @@ AC_ARG_WITH(mantype,
1872 ] 1877 ]
1873) 1878)
1874if test -z "$MANTYPE"; then 1879if test -z "$MANTYPE"; then
1875 AC_PATH_PROGS(NROFF, nroff awf, /bin/false, /usr/bin:/usr/ucb) 1880 TestPath="/usr/bin${PATH_SEPARATOR}/usr/ucb"
1881 AC_PATH_PROGS(NROFF, nroff awf, /bin/false, $TestPath)
1876 if ${NROFF} -mdoc ${srcdir}/ssh.1 >/dev/null 2>&1; then 1882 if ${NROFF} -mdoc ${srcdir}/ssh.1 >/dev/null 2>&1; then
1877 MANTYPE=doc 1883 MANTYPE=doc
1878 elif ${NROFF} -man ${srcdir}/ssh.1 >/dev/null 2>&1; then 1884 elif ${NROFF} -man ${srcdir}/ssh.1 >/dev/null 2>&1; then