summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90eebf5fd..e2289cd37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4070,6 +4070,30 @@ AC_ARG_WITH([kerberos5],
4070AC_SUBST([GSSLIBS]) 4070AC_SUBST([GSSLIBS])
4071AC_SUBST([K5LIBS]) 4071AC_SUBST([K5LIBS])
4072 4072
4073# Check whether user wants ConsoleKit support
4074CONSOLEKIT_MSG="no"
4075LIBCK_CONNECTOR=""
4076AC_ARG_WITH(consolekit,
4077 [ --with-consolekit Enable ConsoleKit support],
4078 [ if test "x$withval" != "xno" ; then
4079 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
4080 if test "$PKGCONFIG" != "no"; then
4081 AC_MSG_CHECKING([for ck-connector])
4082 if $PKGCONFIG --exists ck-connector; then
4083 CKCON_CFLAGS=`$PKGCONFIG --cflags ck-connector`
4084 CKCON_LIBS=`$PKGCONFIG --libs ck-connector`
4085 CPPFLAGS="$CPPFLAGS $CKCON_CFLAGS"
4086 SSHDLIBS="$SSHDLIBS $CKCON_LIBS"
4087 AC_MSG_RESULT([yes])
4088 AC_DEFINE(USE_CONSOLEKIT, 1, [Define if you want ConsoleKit support.])
4089 CONSOLEKIT_MSG="yes"
4090 else
4091 AC_MSG_RESULT([no])
4092 fi
4093 fi
4094 fi ]
4095)
4096
4073# Looking for programs, paths and files 4097# Looking for programs, paths and files
4074 4098
4075PRIVSEP_PATH=/var/empty 4099PRIVSEP_PATH=/var/empty
@@ -4871,6 +4895,7 @@ echo " MD5 password support: $MD5_MSG"
4871echo " libedit support: $LIBEDIT_MSG" 4895echo " libedit support: $LIBEDIT_MSG"
4872echo " Solaris process contract support: $SPC_MSG" 4896echo " Solaris process contract support: $SPC_MSG"
4873echo " Solaris project support: $SP_MSG" 4897echo " Solaris project support: $SP_MSG"
4898echo " ConsoleKit support: $CONSOLEKIT_MSG"
4874echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 4899echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
4875echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 4900echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
4876echo " BSD Auth support: $BSD_AUTH_MSG" 4901echo " BSD Auth support: $BSD_AUTH_MSG"