summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a7b8e8000..aee387190 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.304 2005/11/10 03:46:49 dtucker Exp $ 1# $Id: configure.ac,v 1.305 2005/11/10 10:30:36 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -85,13 +85,14 @@ AC_CHECK_DECL(LLONG_MAX, have_llong_max=1, , [#include <limits.h>])
85 85
86if test "$GCC" = "yes" || test "$GCC" = "egcs"; then 86if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
87 CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wuninitialized" 87 CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wuninitialized"
88 GCC_VER=`$CC --version` 88 GCC_VER=`$CC -v 2>&1 | awk '/gcc version /{print $3}'`
89 case $GCC_VER in 89 case $GCC_VER in
90 1.*) ;; 90 1.*) ;;
91 2.8* | 2.9*) CFLAGS="$CFLAGS -Wsign-compare" ;; 91 2.8* | 2.9*) CFLAGS="$CFLAGS -Wsign-compare" ;;
92 2.*) ;; 92 2.*) ;;
93 3.*) CFLAGS="$CFLAGS -Wsign-compare" ;; 93 3.*) CFLAGS="$CFLAGS -Wsign-compare" ;;
94 *) CFLAGS="$CFLAGS -Wsign-compare -Wno-pointer-sign" ;; 94 4.*) CFLAGS="$CFLAGS -Wsign-compare -Wno-pointer-sign" ;;
95 *) ;;
95 esac 96 esac
96 97
97 if test -z "$have_llong_max"; then 98 if test -z "$have_llong_max"; then