summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7f160f131..f5c65c5a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4113,6 +4113,30 @@ AC_ARG_WITH([kerberos5],
4113AC_SUBST([GSSLIBS]) 4113AC_SUBST([GSSLIBS])
4114AC_SUBST([K5LIBS]) 4114AC_SUBST([K5LIBS])
4115 4115
4116# Check whether user wants ConsoleKit support
4117CONSOLEKIT_MSG="no"
4118LIBCK_CONNECTOR=""
4119AC_ARG_WITH(consolekit,
4120 [ --with-consolekit Enable ConsoleKit support],
4121 [ if test "x$withval" != "xno" ; then
4122 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
4123 if test "$PKGCONFIG" != "no"; then
4124 AC_MSG_CHECKING([for ck-connector])
4125 if $PKGCONFIG --exists ck-connector; then
4126 CKCON_CFLAGS=`$PKGCONFIG --cflags ck-connector`
4127 CKCON_LIBS=`$PKGCONFIG --libs ck-connector`
4128 CPPFLAGS="$CPPFLAGS $CKCON_CFLAGS"
4129 SSHDLIBS="$SSHDLIBS $CKCON_LIBS"
4130 AC_MSG_RESULT([yes])
4131 AC_DEFINE(USE_CONSOLEKIT, 1, [Define if you want ConsoleKit support.])
4132 CONSOLEKIT_MSG="yes"
4133 else
4134 AC_MSG_RESULT([no])
4135 fi
4136 fi
4137 fi ]
4138)
4139
4116# Looking for programs, paths and files 4140# Looking for programs, paths and files
4117 4141
4118PRIVSEP_PATH=/var/empty 4142PRIVSEP_PATH=/var/empty
@@ -4914,6 +4938,7 @@ echo " MD5 password support: $MD5_MSG"
4914echo " libedit support: $LIBEDIT_MSG" 4938echo " libedit support: $LIBEDIT_MSG"
4915echo " Solaris process contract support: $SPC_MSG" 4939echo " Solaris process contract support: $SPC_MSG"
4916echo " Solaris project support: $SP_MSG" 4940echo " Solaris project support: $SP_MSG"
4941echo " ConsoleKit support: $CONSOLEKIT_MSG"
4917echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 4942echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
4918echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 4943echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
4919echo " BSD Auth support: $BSD_AUTH_MSG" 4944echo " BSD Auth support: $BSD_AUTH_MSG"