summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac69
1 files changed, 41 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index 1b8aa5e1c..acbfe78bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.57 2002/05/13 00:48:58 djm Exp $ 1# $Id: configure.ac,v 1.58 2002/05/13 03:15:43 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -1792,6 +1792,17 @@ AC_ARG_WITH(rsh,
1792 ] 1792 ]
1793) 1793)
1794 1794
1795PRIVSEP_PATH=/var/empty
1796AC_ARG_WITH(privsep-path,
1797 [ --with-privsep-path=xxx Path for privilege seperation chroot ],
1798 [
1799 if test "x$withval" != "$no" ; then
1800 PRIVSEP_PATH=$withval
1801 fi
1802 ]
1803)
1804AC_SUBST(PRIVSEP_PATH)
1805
1795AC_ARG_WITH(xauth, 1806AC_ARG_WITH(xauth,
1796 [ --with-xauth=PATH Specify path to xauth program ], 1807 [ --with-xauth=PATH Specify path to xauth program ],
1797 [ 1808 [
@@ -2363,41 +2374,43 @@ D=`eval echo ${sysconfdir}` ; D=`eval echo ${D}`
2363E=`eval echo ${libexecdir}/ssh-askpass` ; E=`eval echo ${E}` 2374E=`eval echo ${libexecdir}/ssh-askpass` ; E=`eval echo ${E}`
2364F=`eval echo ${mandir}/${mansubdir}X` ; F=`eval echo ${F}` 2375F=`eval echo ${mandir}/${mansubdir}X` ; F=`eval echo ${F}`
2365G=`eval echo ${piddir}` ; G=`eval echo ${G}` 2376G=`eval echo ${piddir}` ; G=`eval echo ${G}`
2366H=`eval echo ${user_path}` ; H=`eval echo ${H}` 2377H=`eval echo ${PRIVSEP_PATH}` ; H=`eval echo ${H}`
2367I=`eval echo ${superuser_path}` ; I=`eval echo ${I}` 2378I=`eval echo ${user_path}` ; I=`eval echo ${I}`
2379J=`eval echo ${superuser_path}` ; J=`eval echo ${J}`
2368 2380
2369echo "" 2381echo ""
2370echo "OpenSSH has been configured with the following options:" 2382echo "OpenSSH has been configured with the following options:"
2371echo " User binaries: $B" 2383echo " User binaries: $B"
2372echo " System binaries: $C" 2384echo " System binaries: $C"
2373echo " Configuration files: $D" 2385echo " Configuration files: $D"
2374echo " Askpass program: $E" 2386echo " Askpass program: $E"
2375echo " Manual pages: $F" 2387echo " Manual pages: $F"
2376echo " PID file: $G" 2388echo " PID file: $G"
2389echo " Privilege separation chroot path: $H"
2377if test "$USES_LOGIN_CONF" = "yes" ; then 2390if test "$USES_LOGIN_CONF" = "yes" ; then
2378echo " At runtime, sshd will use the path defined in /etc/login.conf" 2391echo " At runtime, sshd will use the path defined in /etc/login.conf"
2379else 2392else
2380echo " sshd default user PATH: $H" 2393echo " sshd default user PATH: $I"
2381fi 2394fi
2382if test ! -z "$superuser_path" ; then 2395if test ! -z "$superuser_path" ; then
2383echo " sshd superuser user PATH: $I" 2396echo " sshd superuser user PATH: $J"
2384fi 2397fi
2385echo " Manpage format: $MANTYPE" 2398echo " Manpage format: $MANTYPE"
2386echo " PAM support: ${PAM_MSG}" 2399echo " PAM support: ${PAM_MSG}"
2387echo " KerberosIV support: $KRB4_MSG" 2400echo " KerberosIV support: $KRB4_MSG"
2388echo " KerberosV support: $KRB5_MSG" 2401echo " KerberosV support: $KRB5_MSG"
2389echo " Smartcard support: $SCARD_MSG" 2402echo " Smartcard support: $SCARD_MSG"
2390echo " AFS support: $AFS_MSG" 2403echo " AFS support: $AFS_MSG"
2391echo " S/KEY support: $SKEY_MSG" 2404echo " S/KEY support: $SKEY_MSG"
2392echo " TCP Wrappers support: $TCPW_MSG" 2405echo " TCP Wrappers support: $TCPW_MSG"
2393echo " MD5 password support: $MD5_MSG" 2406echo " MD5 password support: $MD5_MSG"
2394echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 2407echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
2395echo " Use IPv4 by default hack: $IPV4_HACK_MSG" 2408echo " Use IPv4 by default hack: $IPV4_HACK_MSG"
2396echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 2409echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
2397echo " BSD Auth support: $BSD_AUTH_MSG" 2410echo " BSD Auth support: $BSD_AUTH_MSG"
2398echo " Random number source: $RAND_MSG" 2411echo " Random number source: $RAND_MSG"
2399if test ! -z "$USE_RAND_HELPER" ; then 2412if test ! -z "$USE_RAND_HELPER" ; then
2400 echo " ssh-rand-helper collects from: $RAND_HELPER_MSG" 2413echo " ssh-rand-helper collects from: $RAND_HELPER_MSG"
2401fi 2414fi
2402 2415
2403echo "" 2416echo ""