summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 615fec2a5..9d3593aa4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.85 2002/08/14 01:52:11 tim Exp $ 1# $Id: configure.ac,v 1.86 2002/09/04 13:26:30 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -98,7 +98,16 @@ case "$host" in
98 AC_DEFINE(IP_TOS_IS_BROKEN) 98 AC_DEFINE(IP_TOS_IS_BROKEN)
99 ;; 99 ;;
100*-*-darwin*) 100*-*-darwin*)
101 AC_DEFINE(BROKEN_GETADDRINFO) 101 AC_MSG_CHECKING(if we have working getaddrinfo)
102 AC_TRY_RUN([#include <mach-o/dyld.h>
103main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
104 exit(0);
105 else
106 exit(1);
107}], [AC_MSG_RESULT(working)],
108 [AC_MSG_RESULT(buggy)
109 AC_DEFINE(BROKEN_GETADDRINFO)],
110 [AC_MSG_RESULT(assume it is working)])
102 ;; 111 ;;
103*-*-hpux10.26) 112*-*-hpux10.26)
104 if test -z "$GCC"; then 113 if test -z "$GCC"; then
@@ -175,6 +184,7 @@ mips-sony-bsd|mips-sony-newsos4)
175 SONY=1 184 SONY=1
176 ;; 185 ;;
177*-*-netbsd*) 186*-*-netbsd*)
187 check_for_libcrypt_before=1
178 need_dash_r=1 188 need_dash_r=1
179 ;; 189 ;;
180*-*-freebsd*) 190*-*-freebsd*)
@@ -718,6 +728,12 @@ if test "x$PAM_MSG" = "xyes" ; then
718 ) 728 )
719fi 729fi
720 730
731# Some systems want crypt() from libcrypt, *not* the version in OpenSSL,
732# because the system crypt() is more featureful.
733if test "x$check_for_libcrypt_before" = "x1"; then
734 AC_CHECK_LIB(crypt, crypt)
735fi
736
721# Search for OpenSSL 737# Search for OpenSSL
722saved_CPPFLAGS="$CPPFLAGS" 738saved_CPPFLAGS="$CPPFLAGS"
723saved_LDFLAGS="$LDFLAGS" 739saved_LDFLAGS="$LDFLAGS"