summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 638877edd..f6a0a6926 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
1# $Id: configure.in,v 1.268 2001/03/28 03:03:42 djm Exp $ 1# $Id: configure.in,v 1.269 2001/03/28 04:35:30 djm Exp $
2 2
3AC_INIT(ssh.c) 3AC_INIT(ssh.c)
4 4
@@ -404,6 +404,20 @@ AC_EGREP_CPP(FOUNDIT,
404 ] 404 ]
405) 405)
406 406
407AC_MSG_CHECKING([whether struct dirent allocates space for d_name])
408AC_TRY_RUN(
409 [
410#include <sys/types.h>
411#include <dirent.h>
412int main(void){struct dirent d;return(sizeof(d.d_name)<=sizeof(char));}
413 ],
414 [AC_MSG_RESULT(yes)],
415 [
416 AC_MSG_RESULT(no)
417 AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME)
418 ]
419)
420
407# Check whether user wants S/Key support 421# Check whether user wants S/Key support
408SKEY_MSG="no" 422SKEY_MSG="no"
409AC_ARG_WITH(skey, 423AC_ARG_WITH(skey,